Database/pymongo error after reinstallation

Dear all,

We recently rebuilt our machines with CUDA 10.1 and Ubuntu 20.04 and I have redownloaded and reinstalled cryosparc.
The installation went smoothly, but I have encountered this error when I start/restart cryosparcm:

CryoSPARC is not already running.
database: ERROR (spawn error)
Traceback (most recent call last):
File “”, line 1, in
File “/home/esrf/cryosparc/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/pymongo/”, line 1149, in database_names
File “/home/esrf/cryosparc/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/pymongo/”, line 491, in command
with client._socket_for_reads(read_preference) as (sock_info, slave_ok):
File “/home/esrf/cryosparc/cryosparc2_master/deps/anaconda/lib/python2.7/”, line 17, in enter
File “/home/esrf/cryosparc/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/pymongo/”, line 859, in _socket_for_reads
with self._get_socket(read_preference) as sock_info:
File “/home/esrf/cryosparc/cryosparc2_master/deps/anaconda/lib/python2.7/”, line 17, in enter
File “/home/esrf/cryosparc/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/pymongo/”, line 823, in _get_socket
server = self._get_topology().select_server(selector)
File “/home/esrf/cryosparc/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/pymongo/”, line 214, in select_server
File “/home/esrf/cryosparc/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/pymongo/”, line 189, in select_servers
pymongo.errors.ServerSelectionTimeoutError: localhost:39001: [Errno 111] Connection refused

I have been reading the topics on this matter and have deleted the /tmp .sock file checked that there are no zombie processes.

The command cryosparcm log database gives me this:

cryosparcm log database
2020-10-29T13:07:24.163+0100 I STORAGE [initandlisten] exception in initAndListen: 98 Unable to lock file: /home/esrf/cryosparc/database/mongod.lock Resource temporarily unavailable. Is a mongod instance already running?, terminating
2020-10-29T13:07:24.163+0100 I NETWORK [initandlisten] shutdown: going to close listening sockets…
2020-10-29T13:07:24.163+0100 I NETWORK [initandlisten] shutdown: going to flush diaglog…
2020-10-29T13:07:24.163+0100 I CONTROL [initandlisten] now exiting
2020-10-29T13:07:24.163+0100 I CONTROL [initandlisten] shutting down with code:100
2020-10-29T13:07:27.241+0100 I CONTROL [initandlisten] MongoDB starting : pid=3068559 port=39001 dbpath=/home/esrf/cryosparc/database 64-bit host=cmproc1
2020-10-29T13:07:27.241+0100 I CONTROL [initandlisten] db version v3.4.10-4-g67ee356c6b
2020-10-29T13:07:27.241+0100 I CONTROL [initandlisten] git version: 67ee356c6be377cda547d16423daef5beb4e8377
2020-10-29T13:07:27.241+0100 I CONTROL [initandlisten] OpenSSL version: OpenSSL 1.0.2p 14 Aug 2018
2020-10-29T13:07:27.241+0100 I CONTROL [initandlisten] allocator: tcmalloc
2020-10-29T13:07:27.241+0100 I CONTROL [initandlisten] modules: none
2020-10-29T13:07:27.241+0100 I CONTROL [initandlisten] build environment:
2020-10-29T13:07:27.241+0100 I CONTROL [initandlisten] distarch: x86_64
2020-10-29T13:07:27.241+0100 I CONTROL [initandlisten] target_arch: x86_64
2020-10-29T13:07:27.241+0100 I CONTROL [initandlisten] options: { net: { port: 39001 }, replication: { oplogSizeMB: 64, replSet: “meteor” }, storage: { dbPath: “/home/esrf/cryosparc/database”, journal: { enabled: false }, wiredTiger: { engineConfig: { cacheSizeGB: 4.0 } } } }

How can I get the program up and running again?

Thank you very much in advance,


Hi David,

Are you by any chance installing inside an anaconda environment? If so, deactivate and try again. I ran into some similar issues recently (on Linux mint 20) and that was because of cuda driver corruption and gcc and g++ libraries not being present. I’d recommend looking into those and maybe even upgrade your cuda to 10.2 (don’t go to 11, cryosparc doesn’t support it yet). And before reinstalling cryosparc, restart your computer for good measure. Good luck



Hi Vamsee,

Thank you for your input. We have finally managed to solve the issue.
The reason why we were getting this error was that there was a mongod.lock file inside the database folder from the previous program’s backup that did not get properly deleted
Deleting this file solved everything.