Database fatal on v3.3.1+211214

I tried to run cryosparcm backup and got the error: “Starting the database in case it’s not already running. database: ERROR (spawn error)”

CryoSPARC process status:

app STOPPED Not started
app_dev STOPPED Not started
command_core STOPPED Not started
command_rtp STOPPED Not started
command_vis STOPPED Not started
database FATAL Exited too quickly (process log may have details)
liveapp STOPPED Not started
liveapp_dev STOPPED Not started
webapp STOPPED Not started
webapp_dev STOPPED Not started

cryoSPARC appeared to be running and the webapp was accessible. I did not try to run any jobs. A recent action was to clear intermediate results for all projects ~ 2 days prior. Just prior to this error I rsync’d my database/results to a backup.

I tried cryosparcm restart without luck (database: ERROR (spawn error)) and some jobs persist with cryosparcm stop, so I killed all ghost jobs and will try to repair the database as described here.

I was not running a lot of heavy jobs. Any idea what causes this and how to avoid it? Hopefully, it can be recovered.

Recovery seems to have worked! Thanks to the instructions from @stephan here

In short,
Kill all processes after checking with “ps -ax | grep cryosparc” as described here
backup/rsync /software/cryosparc/* to an external just in case
Then Stephan’s commands to restore the database:
eval $(cryosparcm env)
cd cryosparc2_database
mongod --dbpath ./ --repair

cryosparcm start and “Database configuration is OK.”