Cufft library not found

CryoSPARC installation seemed to complete fine. However my first job is failing and I can see the following in the log file:

File “cryosparc2_compute/engine/”, line 8, in
from engine import *
File “cryosparc2_worker/cryosparc2_compute/engine/”, line 12, in init cryosparc2_compute.engine.engine
File “cryosparc2_worker/cryosparc2_compute/engine/”, line 6, in init cryosparc2_compute.engine.gfourier
File “/projappl/project_2001566/usrappl/huiskone/cryosparc2_worker/deps/anaconda/lib/python2.7/site-packages/skcuda/”, line 14, in
from . import cufft
File “/projappl/project_2001566/usrappl/huiskone/cryosparc2_worker/deps/anaconda/lib/python2.7/site-packages/skcuda/”, line 46, in
raise OSError(‘cufft library not found’)
OSError: cufft library not found

Please let me know how to troubleshoot this, many thanks.

The solution was to remove “ssh [login node]” from the job submission command in cluster_info.json (“send_cmd_tpl” : “{{ command }}”) and connect the worked again. It seems that in my environment this ssh step is not needed - doing this resets the environment variables and then libraries are not found anymore.

1 Like

I have the same error, Ubuntu 20.04, current cryosparc2 install.
Made sense to edit the file you named, but I’m having an issue finding it.
Single node install, master and worker are the same machine, but looking in
my installation root which contains both file systems I’m unable to find the cluster_info.json file.

Did I miss installing something, or type the find?

root@suraj:/home/cryosparc_user# ls
cryosparc2_database cryosparc2_master cryosparc2_master.tar.gz cryosparc2_worker cryosparc2_worker.tar.gz
root@suraj:/home/cryosparc_user# find . -print | grep cluster_info.json

Same result with a # find from the root of the file system.