CUDA 10.1 Support in v2.8.3?

I just added one of our new machines as a worker. I upgraded the cuda to 10.1 and reinstalled pycuda as mentioned in one of the posts here.

Right now, I am seeing this error when I run a full-frame motion correction job. Any ideas?

The machine in question is running a threadripper cpu with four 2080’s

Traceback (most recent call last):
File “cryosparc2_worker/cryosparc2_compute/”, line 78, in (/home/installtest/deps_manage/cryosparc2_package/deploy/stage/cryosparc2_worker/cryosparc2_compute/run.c:3954)
File “cryosparc2_worker/cryosparc2_compute/jobs/motioncorrection/”, line 301, in (/home/installtest/deps_manage/cryosparc2_package/deploy/stage/cryosparc2_worker/cryosparc2_compute/jobs/motioncorrection/run.c:10100)
File “cryosparc2_compute/engine/”, line 8, in
from engine import *
File “cryosparc2_worker/cryosparc2_compute/engine/”, line 12, in init cryosparc2_compute.engine.engine (/home/installtest/deps_manage/cryosparc2_package/deploy/stage/cryosparc2_worker/cryosparc2_compute/engine/engine.c:40577)
File “cryosparc2_worker/cryosparc2_compute/engine/”, line 6, in init cryosparc2_compute.engine.gfourier (/home/installtest/deps_manage/cryosparc2_package/deploy/stage/cryosparc2_worker/cryosparc2_compute/engine/gfourier.c:3861)
File “/csparc/cryosparc-worker/cryosparc2_worker/deps/anaconda/lib/python2.7/site-packages/skcuda/”, line 20, in
from . import misc
File “/csparc/cryosparc-worker/cryosparc2_worker/deps/anaconda/lib/python2.7/site-packages/skcuda/”, line 25, in
from . import cublas
File “/csparc/cryosparc-worker/cryosparc2_worker/deps/anaconda/lib/python2.7/site-packages/skcuda/”, line 292, in
_cublas_version = int(_get_cublas_version())
File “/csparc/cryosparc-worker/cryosparc2_worker/deps/anaconda/lib/python2.7/site-packages/skcuda/”, line 285, in _get_cublas_version
h = cublasCreate()
File “/csparc/cryosparc-worker/cryosparc2_worker/deps/anaconda/lib/python2.7/site-packages/skcuda/”, line 203, in cublasCreate
File “/csparc/cryosparc-worker/cryosparc2_worker/deps/anaconda/lib/python2.7/site-packages/skcuda/”, line 179, in cublasCheckStatus
raise e

It looks like the error is related to scikit-cuda package. I tried re-installing it via pip but it didn’t work.

Hi @achintangal,

It looks like scikit-cuda has only recently added support for CUDA 10.1, but its not released yet (looks like it will be released in scikit-cuda 0.5.3):

Until then, please use CUDA 10.0 with cryoSPARC. As soon as scikit-cuda 0.5.3 is released I will update cryoSPARC and release it!

Edit: I just realized scikit-cuda 0.5.3 has already been released. Expect a new release of cryoSPARC soon.

Great! Will it give it a shot and update you folks!

Hi @achintangal,

If you’d like, try installing the latest version of scikit-cuda and see if that works?