cryoSPRAC v2 installation problem


I have been trying to install cryoSPARC v2 into our Linux workstation (run by Centos7). I was simply following the script provided. It looks like the file “cryosparc2_master.tar.gz” was downloaded. However, when I tried to run the script “tar -xf cryosparc2_master.tar.gz”, I was getting the following error message:
“This does not look like a tar archive
gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error is not recoverable: exiting now”

I would appreciate if someone let me know how to solve this problem - so I can install version 2

Thanks for your help


Hi @yurotakagi

Can you make sure that your $LICENSE_ID variable is set?



Thanks for your response. echo did not show license ID. But I ran export LICENSE_ID=“the one I got from email”


Using the curl function without setting the $LICENSE_ID variable properly will cause it to download an invalid tar file. Please ensure this variable is set correctly.

Thanks for your help. But I ran the following script provided by instruction:

export LICENSE_ID=“xxxxxx”

curl -L$xxxxxx > cryosparc2_master.tar.gz

I am not good at dealing with computer. If this script did not set up $LICENSE_ID, I don’t know how to set it up correctly


It looks like I was able to fix LICENSE_ID problem: run echo and the id shows up. Then, I can’t download cryosparc2_master.tar.gz by running “curl -L$xxxxxx > cryosparc2_master.tar.gz” The error message said “it can’t resolve the host,

Is this host problem or am I doing something wrong?

So frustrating.