Cryosparcw newcuda & cuda 12

Dear colleagues,

2 Quick questions -

  1. when I want to re-assign cuda to cuda 11.8 using command
    #cryosparcw newcuda /usr/local/cuda-11.8

I am getting the following error
#command not found…

  1. Will the CS work with cuda 12?

Thank you in advance.


Hi Dmitry - cryosparcw will not be in your system PATH - that is why you are getting the error about the command not being found.

You will need to run it from wherever the worker directory is located - something like whatever/cryosparc/cryosparc_worker/bin/cryosparcw.

If you don’t know where it is, check the location of cryosparcm - using which cryosparcm - as the directories will be adjacent.


1 Like

hi Oli @olibclarke,

Thank you for your answer.

I tried to get into the cryosparc_worker/bin/ and execute again the command.
But something again did not worked for me

Additionally, the cryosparcw doesnot seem to be a folder in my case.

The command which cryosparcm leads to

Is something not correct with my system?

Thank you in advance.


Hi Dmitry,

If you want to run an executable from a folder you are currently in, you need to put “./” in front of the command:

./cryosparcw newcuda

Or you can specify the full path to the executable without having to cd into the folder first:

/full/path/to/cryosparcw newcuda

dear @boggild,

thank you.

Everything worked well as you and @olibclarke Oli advised.

Kind regards,

No, no it won’t. :frowning:

Fortunately, as I think (?) you’ve discovered, it is possible to run multiple CUDA versions. :slight_smile:

1 Like

dear @rbs_sci,

yes indeed, in the installation recommendations it says that the upper version of Cuda is 11.8.

I hoped that this info was already outdated but it is apparently not :).

Thank you!

Kind regards,

1 Like

Hi Team,
I am also looking for answers as it relates to CUDA 12 support…any clues when we will have some sort of Beta/RC release for this…I am willing to be a tester if possible. Thank you in advance. LG