cryoSPARC v. 2.13.2 standalone installation not start in web browser

closed

#1

I have fresh install “cryoSPARC v. 2.13.2 standalone” in CentOS 7.7 workstation today.
I don’t see any error during installation, but http://localhost:39000 doesn’t start.
Please help.Thansk.


#2

Hi @wenhwai

Please ensure your firewall is not blocking ports 39000 to 39010. Try restarting cryoSPARC:

cryosparcm restart

If the issue persists, please share the output of:

cryosparcm status

(Do not include any personal info such as your license ID)

Thanks,
Suhail


#3

Hi Suhail,

Please look at below for the information of cryosparcm restart and cryosparcm status
There has been shown some Errors.
Thanks a lot.
Wen

[emma@xray1 ~]$ cryosparcm restart
CryoSPARC is running.
Stopping cryosparc.
unix:///tmp/cryosparc-supervisor-0a7a1b70e8cb83ee5e3d996ff3c14f1f.sock refused connection
ERROR: unix:///tmp/cryosparc-supervisor-0a7a1b70e8cb83ee5e3d996ff3c14f1f.sock refused connection (already shut down?)
Starting cryoSPARC System master process..
CryoSPARC is already running.
If you would like to restart, use cryosparcm restart

[emma@xray1 ~]$ cryosparcm status
----------------------------------------------------------------------------
CryoSPARC System master node installed at
/usr/local/cryosparc/cryosparc2_master
Current cryoSPARC version: v2.13.2
----------------------------------------------------------------------------

cryosparcm process status:

unix:///tmp/cryosparc-supervisor-0a7a1b70e8cb83ee5e3d996ff3c14f1f.sock refused connection

#4

Hi @wenhwai,

  1. Ensure cryoSPARC is turned off:
    cryosparcm stop
  2. Then, ensure no zombie processes are still running. Kill the processes if they are.
    ps -ax | grep “supervisord” (kill only the process that is running from your cryosparc2 install)
    ps -ax | grep “cryosparc2_command” (kill all the matching processes related to your cryosparc2 
    instance)
    ps -ax | grep “mongod” (kill only the process running your cryosparc2 database)
    
    e.g. kill 82681
    
  3. Remove the socket file inside the /tmp folder
    /tmp/cryosparc-supervisor...XXX.sock
  4. Start cryoSPARC:
    cryosparcm start

Please let me know if this resolves the issue.

Thanks,
Suhail


#5

It is working.
Thanks a lot.
Wen