Cryosparc stopped working after update: Distribution not found


I am getting the following error after updating the cryosparc. Any idea how I can fix this?

    Traceback (most recent call last):
  File "/home/singhpk/software/cryosparc/cryosparc2_master/deps/anaconda/bin/supervisorctl", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/home/singhpk/software/cryosparc/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/pkg_resources/", line 3251, in <module>
  File "/home/singhpk/software/cryosparc/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/pkg_resources/", line 3235, in _call_aside
    f(*args, **kwargs)
  File "/home/singhpk/software/cryosparc/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/pkg_resources/", line 3264, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/home/singhpk/software/cryosparc/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/pkg_resources/", line 583, in _build_master
  File "/home/singhpk/software/cryosparc/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/pkg_resources/", line 900, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/home/singhpk/software/cryosparc/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/pkg_resources/", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: **The 'supervisor==3.3.3' distribution was not found and is required by the application**

Hi @prash, this may indicate that cryoSPARC’s dependencies didn’t fully finish installing. Log in via terminal to the machine where cryoSPARC is installed and run the following command:

cryosparcm forcedeps

Then restart cryoSPARC with cryosparcm restart

Let me know how that goes.


After successful installation of dependencies, I am now getting this error when I try to restart:

home/singhpk/software/cryosparc/cryosparc2_master/bin/cryosparcm: line 111: supervisorctl: command not found

Hi @prash, apologies for the delay. Something’s definitely going wrong with the dependency installation. I recommend is a fresh installation: Delete the cryosparc2_master and cryosparc2_worker directories (keep the database directory) and try the installation instructions here:

If you keep the same parameters you used as when you first installed cryoSPARC, you can skip the “connect worker” step and all your data will be preserved.

If applicable, be sure to deactivate any Conda environments you already have installed before trying this.

Let me know how that goes

Thank you @nfrasser. The reinstall fixed it and my data was safely restored.

1 Like

Hi @nfrasser,

This is just an update on the issue and also a note to myself. I encountered the same error again and this time I did the following and the error was resolved.

> cryosparcm stop
(will probably give error)

Restart the system
Open bash terminal

> cryosparcm forcedeps
(take about 15 mins)

Delete .sock file from /tmp/

> cryosparcm start