Cryosparc stays in queue/cannot find user


Recently our workstation encountered a power outage while cryosparc was running. After restarting the workstation I cannot login to the workstation anymore. Our IT department helped us reboot the system, but somehow all information of cryosparc user accounts disappeared, which means I cannot login with my previous cryosparc account (with error “user not find”). So I created a new account, and imported my old working categories. Cryosparc can display thumbnails of old jobs, but it cannot run any new job and keep staying in queue status (shown in picture). I tried to update cryosparc but it didn’t help. We are hesitating to reinstall cryosparc because we don’t want to lose our jobs. Could anyone help with this? Thank you very much!


stop cryoparc and look in the /tmp folder.
Delete any .sock files.
restart cryosparc

Hi @MHB,

There is no .sock file in /tmp, and restart cryosparc didn’t fix the problem

there should be a file called something like cryosparc-supervisor-b10c8768f557ad70f31ce376b22cebcf.sock in your /tmp directory if cryosparc is running. Can you find this type of file anywhere?

Hi @MHB,

I can find two sock file in /tmp when cryosparc is running. After deleting them and restart, I got the message like below:

[cryosparc@as-chm-cran-22 tmp]$ cryosparcm start
Starting cryoSPARC System master process..
CryoSPARC is not already running.
database: ERROR (spawn error)
command_core: started
  cryosparc command core startup complete.
command_vis: started
command_proxy: ERROR (spawn error)
webapp: started

CryoSPARC master started. 
 From this machine, access cryoSPARC at

 From other machines on the network, access cryoSPARC at

Startup can take several minutes. Point your browser to the address
and refresh until you see the cryoSPARC web interface.

Unfortunately when I started a new job, it still queued there and nothing happened.

can you try this
stop cryosparc
kill any background cryosparc jobs, you can check with this command
ps -ax | grep “supervisord”
delete all .sock files in the /tmp directory
start cryosparc

Hi @MHB,

I killed both child process and parent process of supervisord, and it still didn’t work.

BTW, I noticed that cryosparc now gives an error of “list index out of range”.

Ok i think i have exhausted the fixes that have worked for me in the past. If i find something else will let you know.

Thank you! I will also keep trying and updating

Hi @MHB,

We thought it was database issue, and we used the databases that backed up before, but none of them worked. After freshly reinstalling CryoSparc, we finally fixed the issue. Although we lose all the user information, jobs can still be recovered by importing.


Ok thanks for letting me know. Glad your back and runnung.

Hi @Feng10,

The initial problem was most likely caused by two instances of cryoSPARC running at the same time. Your best bet would’ve been to stop cryoSPARC fully, then kill any processes and delete any temporary .sock files like @MHB mentioned before restarting again. To find out the reason for the database: ERROR (spawn error) message, you should run cryosparcm log database, which may shed some light on the reason it failed to start (most likely a locked database). Sorry I didn’t get to respond to this sooner!

Hi @stephan,

Thanks for your reply! I will keep your suggestion in my mind.