cryoSPARC Re-install problem

Hi all,

I am trying to re-install cryoSPARCV2.15 (–standalone) on a workstation because of the same database spawn error discussed here: Database: ERROR (spawn error)

I am now trying to reinstall so I can import my old database/instance, but I am now experiencing issues similar to what has been discussed here: Installation problems about Cryosparc2.11

I have tried using cyrosparcm stop and the output is the following:

CryoSPARC is running.
Stopping cryosparc 
unix:///tmp/cryosparc-supervisor-19926dcc439c23d73ac259ba81582779.sock refused connection
ERROR: unix:///tmp/cryosparc-supervisor-19926dcc439c23d73ac259ba81582779.sock refused connection (already shut down?)

I’ve also made sure that now orphaned cryoSPARC processes are running with the following commands:

ps -ax | grep “supervisord”
ps -ax | grep “cryosparc2_command”
ps -ax | grep “mongodb"

and I’m now at a loss for how to get cryoSPARC back up and running :cry:

Any advice you have would be greatly appreciated.

thanks so much!
-jonny

Hi @Cryo_EM_Jonny, do you still get this error when you restart the workstation and run cryosparcm start?

If so, can you send me the database log file at cryosparc2_master/run/database.log for further troubleshooting?

Hi @nfrasser–thanks so much for reaching out to help!

I rebooted from the command line and now when I run cryosparcm start, the output is the following:

ERROR: Re-run this command on the master node: localhost.
Alternatively, set CRYOSPARC_FORCE_HOSTNAME=true in cryosparc2_master/config.sh to suppress this error.
If this error message is incorrect, set CRYOSPARC_HOSTNAME_CHECK to the correct hostname in cryosparc2_master/config.sh.

So I now suspect this is because I don’t have cryosparc properly installed on the workstation anymore… I will give the installation another go shortly…

Hi @nfrasser–dang! Just tried to run the install.sh script in the cryosparc2_master directory, and still got that same error I referenced in the original post (Installation problems about Cryosparc2.11)

Sadly, there is no database.log file in the cryosparc2_master/run/ folder :confused:

Thanks again for your help.

-jonny

Hi @Cryo_EM_Jonny, you got that error because you ran cryosparcm start, then ./install.sh without running cryosparcm stop. Based on this I would suggest a brand new cryoSPARC installation inside a different folder.

Restart your workstation and delete the current cryosparc2_master and cryosparc2_worker folders (not the database folder). Then choose a different folder into which to install cryosparc re-do the steps here:
https://guide.cryosparc.com/setup-configuration-and-management/how-to-download-install-and-configure

  • Make sure you are not logged in as root or use sudo at any point in the process
  • Use a different installation directory. For example, if you previously had cryosparc installed at /home/user/cryosparc/, make a new directory at /user/home/cryosparc_reinstall (or similar) and download and install cryoSPARC there.
  • When you run ./install.sh use the same database folder from you old instance
  • Skip the “Create the first user” step

If you still get a database spawn error, send me the entire contents of the new cryosparc2_master/run directory.

Nick

Hi Jonny, any updates on this?