Cryosparc ping: socket: Operation not permitted


After updating to the new CryoSPARC version 4.0.1, I have run in to many issues. The first issue was that jobs were being hung on launch which did not produce any errors. I then chose to do a fresh install of cryoSPARC to fix this and am now having the following issues.

After running ./ in the cryosparc_master folder, I get the following:

ping: socket: Operation not permitted
Error: Could not ping dt-exxact-01

This has never happened to me before. However, when I run it as root, everything seems to install correctly up until I try to install the cryosparc_worker. I have the following error:

ERROR: This command can only be called by the owner of this script: exx. You are root!
Alternatively, set CRYOSPARC_FORCE_USER=true in cryosparc_master/ to suppress this error.

If exit root and use user exx, I can start cryosparcm just fine. However, now when I go to the cryosparc_worker folder and ./, i get the following error:

Traceback (most recent call last):
File “bin/”, line 221, in
gpu_devidxs = check_gpus()
File “bin/”, line 91, in check_gpus
num_devs = print_gpu_list()
File “bin/”, line 23, in print_gpu_list
import pycuda.driver as cudrv
ModuleNotFoundError: No module named ‘pycuda’

Before this update, I had never had installation issues with CryoSPARC. Can someone please help?

Please can you post the full command you used and the output that precedes these messages:

CryoSPARC should not be installed or run as a privileged user (such as root).

Hi Wtempel,

This is the full command I ran and have run for 2 other systems that are currently working.

./ --license $LICENSE_ID --standalone --worker_path /usr/local/CryoSPARC/cryosparc_worker --cudapath /usr/local/cuda --initial_email “” --initial_password “-------” --initial_username “kherbine” --initial_firstname “Karl” --initial_lastname “Herbine” --ssdpath /mnt/data/

Password omitted.

Please can you provide for a working system and the non-working one outputs of:

  • hostname -f
  • grep MASTER /path/to/cryosparc_master/
  • uname -a

Do the systems’ network environments differ?

Hi wtempel,

I have made a new troubleshooting topic regarding another issue that was resolved by downgrading my CryoSPARC version to V3.4.0. The system’s network environments are the same.

  • Output of non-working system
export CRYOSPARC_MASTER_HOSTNAME="dt-exxact-01"
(base) [exx@dt-exxact-01 CUDA_Install_Files]$ uname -a
Linux dt-exxact-01 3.10.0-1160.66.1.el7.x86_64 #1 SMP Wed May 18 16:02:34 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
(base) [exx@dt-exxact-01 CUDA_Install_Files]$
  • Output of working system
(base) [exx@dt-exxact-02 ~]$ hostname -f
(base) [exx@dt-exxact-02 ~]$ grep MASTER /usr/local/CryoSPARC/cryosparc_master/
export CRYOSPARC_MASTER_HOSTNAME="dt-exxact-02"
(base) [exx@dt-exxact-02 ~]$ uname -a
Linux dt-exxact-02 3.10.0-1160.66.1.el7.x86_64 #1 SMP Wed May 18 16:02:34 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
(base) [exx@dt-exxact-02 ~]$