cryoSPARC Live not seeing data

Hi - I was recently trying to setup a cryoSPARC-Live run on data being acquired by EPU on our G4 Krios. I’m having an odd issue where I can define the folder path the ImageData folder, and normally from here I can set the wild card filter and activate the search recursive and everything is good. However, on this run when I do that cryoSPARC-Live doesn’t see any data. If I go to the main cryoSPARC side however, I can import the same micrographs without any issue. Has anyone seen this before or know where I can even start debugging?

Just to confirm:

You mean that you only change the port number in the browser address bar, but the hostname remains unchanged?

Correct. That’s all that is changing

Please can you try this sequence, escalating to the next step only if the issue hasn’t been resolved at that point:

  1. clear and (re-)start the Live session
  2. add a New exposure group to the session’s configuration and define your data paths and id cards within that new exposure group
  3. cryosparcm restart (which would disrupt running jobs)
  4. reboot the computer
1 Like

Wondering if this was resolved? We have the same issue - in V.4.1.2 - I restarted cryoSPARCm - but this is on our cluster - so rebooting the whole system is a nuclear option that will make people unhappy.

@DaveBhella Please can you email us the file produced by running
cryosparcm snaplogs?
You may also try to

  1. pause the session
  2. then run
    cryosparcm restart command_rtp
  3. (re-)start the session

I have this sitution before. In my case, the time in K3 computer is not correct. As a result, the images wrote to the disk didn’t have correct timestamps (the images have a “future” timestamp). CryoSPARC live seems to ignore these images.
I manage to solve this issue by running a simple command “touch *tif” so that all movies have new timestamps.

Thanks all - in the end we updated and restarted CryoSPARC and everything started behaving.