CryoSPARC job time need to increase

Hi CryoSPARC Team, I would like to increase the wait time of the cryosparc job.
Could you please let me know the default wait time of the cryosparc job in a queue and where this has configured.

Praveen K V

@pvalappil If you are really seeking to delay the start of a compute job that has been queued, please explain under what circumstances and for what reasons the job should be delayed. Also, is your cryoSPARC instance configured to use a compute cluster and a cluster job scheduler?

@wtempel No, my requirement is cryoSPARC job should stay in the queue till the compute node is available, now it stays for some time and then it fails. So I would like to change the default wait time of cryoSPARC jobs. Thanks

@pvalappil The cryoSPARC built-in scheduler should ensure that a scheduled cryoSPARC job does not “collide” with another cryoSPARC job. Does the job fail for reasons other than scheduling or compete with a non-cryoSPARC job for resources?

@wtempel It is just a single job, actually our compute nodes are coming up bit lately, so I would like to increase the wait time from cryoSPARC. Thanks.

@pvalappil This situation may require external (to cryoSPARC) job scheduling.

@wtempel Yes we are using SLURM scheduler and AWS compute nodes take some time to come up, in between I notices job is failing, instead of that it should wait in the queue until the compute nodes are up. I think cryoSAPRC job has some settings due to that it is waiting in the queue for some time, but after that it is failing and not waiting in the queue until the nodes are up. Thanks.

@pvalappil Thank you for providing additional details. You may find the AWS section of the guide useful.

@wtempel sorry I did not find a solution for the problem in the above mentioned URL. I am just asking why cryoSPARC jobs are not staying in the queue until compute nodes are available. The jobs goes into the scheduler queue it wait for some time then it fails. Thanks.