Cryosparc installation with pycuda issue

When i try to install cryosparc master, everything is going well until i got pycuda issue. Please check the attached. Does anyone know what is going on?
Preparing transaction: done
Executing transaction: done
installation finished.

anaconda python installation successful.

Extracting all conda packages…

conda packages installation successful.

Preparing to install all pip packages…

Processing ./deps_bundle/python/python_packages/pip_packages/pycuda-2020.1.tar.gz
Preparing metadata ( … done
Building wheels for collected packages: pycuda
Building wheel for pycuda ( … error
error: subprocess-exited-with-error

× python bdist_wheel did not run successfully.
│ exit code: 1
╰─> [13157 lines of output]
*** I have detected that you have not run
*** Additionally, no global config files were found.
*** I will go ahead with the default configuration.

pe) [with ExceptionType = pycuda::error; Translate = void ()(const pycuda::error&)]’
src/wrapper/wrap_cudadrv.cpp:691:74: required from here
bpl-subset/bpl_subset/boost/function/function_base.hpp:318:54: warning: placement new constructing an object of type ‘pycudaboost::detail::function::functor_manager_common<pycudaboost::_bi::bind_t<bool, pycudaboost::python::detail::translate_exception<pycuda::error, void ()(const pycuda::error&)>, pycudaboost::_bi::list3<pycudaboost::arg<1>, pycudaboost::arg<2>, pycudaboost::_bi::value<void ()(const pycuda::error&)> > > >::functor_type’ {aka ‘pycudaboost::_bi::bind_t<bool, pycudaboost::python::detail::translate_exception<pycuda::error, void ()(const pycuda::error&)>, pycudaboost::_bi::list3<pycudaboost::arg<1>, pycudaboost::arg<2>, pycudaboost::_bi::value<void ()(const pycuda::error&)> > >’} and size ‘16’ in a region of type ‘char’ and size ‘1’ [-Wplacement-new=]
new (reinterpret_cast<void*>(& functor_type(*in_functor);
error: command ‘/usr/bin/gcc’ failed with exit code 1
[end of output]

note: This error originates from a subprocess, and is likely not a problem with pip.
error: legacy-install-failure

× Encountered error while trying to install package.
╰─> pycuda

note: This is an issue with the package mentioned above, not pip.
hint: See above for output from the failure. 66: ERROR: installing python failed.

@zcp Please can you post

  • the command that you ran to get this error. Please conceal any email address, license id, password that may have been included in the command
  • the outputs of these commands
    gcc --version
    nvidia-smi --query-gpu=index,name,driver_version --format=csv
    # based on what you provided for --cudapath
    /path/to/cuda/bin/nvcc --version
    export | grep PATH

[edited: command correction]

Thank you for your quick reply. after i run these commands you mentioned, i got these output beow,
1: ./ --standalone --license “xxxx” --worker_path /usr/homes/xxx/cryosparc/cryosparc_worker --cudapath /usr/local/cuda --ssdpath /scr/ssd-folder --initial_email “xxx” --initial_password “xxx” --initial_username “xxx” --initial_firstname “xxx” --initial_lastname"xxx" --port 39000
2: gcc -version,
gcc: error: unrecognized command line option ‘-version’
gcc: fatal error: no input files
compilation terminated.
3: nvidia-smi --query-gpu=index,name,driver_version --format=csv
index, name, driver_version
0, NVIDIA RTX A6000, 525.116.04
1, NVIDIA RTX A6000, 525.116.04
2, NVIDIA RTX A6000, 525.116.04
3, NVIDIA RTX A6000, 525.116.04
4, NVIDIA RTX A6000, 525.116.04
5, NVIDIA RTX A6000, 525.116.04
6, NVIDIA RTX A6000, 525.116.04
7, NVIDIA RTX A6000, 525.116.04
4:/path/to/cuda/bin/nvcc --version
output: -bash: /path/to/cuda/bin/nvcc: No such file or directory
5: export | grep PATH
output: declare -x LD_LIBRARY_PATH=“/usr/local/relion-4.0/lib:/usr/local/cuda/lib:/usr/local/cuda/lib64:/usr/local/cuda-11.6/lib:/usr/local/cuda-11.6/lib64:/usr/local/cuda-11.3/lib:/usr/local/cuda-11.3/lib64:/usr/local/cuda-11.2/lib:/usr/local/cuda-11.2/lib64:/usr/local/cuda-11.1/lib:/usr/local/cuda-11.1/lib64:/usr/local/cuda-11.0/lib:/usr/local/cuda-11.0/lib64:/usr/local/cuda-10.1/lib:/usr/local/cuda-10.1/lib64:”
declare -x PATH=“/usr/local/relion-4.0/bin:/usr/local/mpich-4.0.3/bin:/usr/local/cuda/bin:/usr/local/IMOD/bin:/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/usr/local/IMOD/pythonLink:/usr/local/motioncorr_v2.1/bin:/usr/local/Gctf_v1.18:/usr/local/ResMap/:/usr/local/cistem-1.0.0-beta/:/usr/local/EMAN_2.91/bin”

Thanks @zcp. I earlier missed a dash character in the gcc command. Please can you run these commands and post their outputs:

gcc --version
readlink -e $(which gcc)
/usr/local/bin/nvcc --version

In case /usr/local/cuda points to a toolkit version 12 or newer, please be aware that 11.8 is the latest version of the toolkit currently supported by CryoSPARC, and that you may have better luck re-trying the installation with --cudapath usr/local/cuda-11.6, if that directory inside your $LD_LIBRARY_PATH does indeed contain a viable toolkit.

Thank you for troubleshooting. I re-run these commonds, it gave output below
1: gcc --version
output: gcc (GCC) 8.5.0 20210514 (Red Hat 8.5.0-18)
Copyright (C) 2018 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
2: readlink -e $(which gcc)
output: /usr/bin/gcc
3: /usr/local/bin/nvcc --version
output: -bash: /usr/local/bin/nvcc: No such file or directory

Sorry. That was a typo.
Please try

/usr/local/cuda/bin/nvcc --version

nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2023 NVIDIA Corporation
Built on Fri_Jan__6_16:45:21_PST_2023
Cuda compilation tools, release 12.0, V12.0.140
Build cuda_12.0.r12.0/compiler.32267302_0

Do you guys know what is going on with installation?

CUDA toolkit v12 or newer is not supported by CryoSPARC v4.3.1.

I tried as you said, but when i got another issue below when i run cryosparcm restart,
CryoSPARC is not already running.
If you would like to restart, use cryosparcm restart
Starting cryoSPARC System master process…
CryoSPARC is not already running.
configuring database
configuration complete
database: started
checkdb success
command_core: ERROR (spawn error)

Hi, i got it fixed. I just log out the Terminal and relog in , it works. Thank you for your guys help