Cryosparc install path changed. Worker updates fail


I recently reinstalled some of the Cryosparc servers from Centos 7 to Rocky 8. When reinstalling Cryosparc, I changed the cryosparc install directory to the path listed in the install guide.

However, the worker didn’t seem to work properly. I tried to override the install. The master worked without issue, but the worker didn’t really through an error, but it failed because the cp is going to the wrong path.

Now updating worker nodes.
All workers:
Updating worker
Direct update
\cp -f ./cryosparc_worker.tar.gz /uufs/
This is a forced update. To finish updating this worker node, log onto the node and run cryosparcw update --override

The path correct path is …cryosparc02sa/cryosparc/cryosparc_worker, but it’s still going to the old path even though I did a clean fresh install.

I got the worker to update by copying the tar file to the worker directory and running cryosparcw update --override. But then hit the same problem trying to install the patch.

Trying the same thing and using the --force option, fails. Somehow, it appears that some environment variable is stuck on the old patch.

CHPC - U of U

The absolute cryosparc_worker/ during an automatic worker update is inferred from scheduler target "worker_bin_path" records in the CryoSPARC database. These records may be outdated in your case and still point to the old cryosparc_worker/ path.
You can view the relevant database records with the command

cryosparcm cli "get_scheduler_targets()"

If you confirm that the database holds outdated records, you can try

  1. manual (“cluster-style”) worker update
  2. then, for each scheduler target, on the given target, run the appropriate
    /abs/path/to/crysparc_worker/bin/cryosparcw connect
    command with the
    --update flag and all other necessary parameters (guide) to update the database records.