Cryosparc fails to run even with previous good datasets


I have tried to run an 2D classification but cryosparc fails to start. It looks like it has a slice is not an intiger. Error is here:

Traceback (most recent call last):
File “/mnt/data1/cryosparc/cryosparc-compute/”, line 542, in
cuda_devs = current_experiment_params[‘cuda_devs’])
File “/mnt/data1/cryosparc/cryosparc-compute/”, line 244, in abinit
sigma_init_mean = n.sqrt(n.mean(sigproc.rotational_average(sigma2_init)[:radwn_max]))
TypeError: slice indices must be integers or None or have an index method

I have tried also old datasets which were working previously fine. The surprising thing is that I havent updated cryosparc and it is running v0.6.5. Do you have any ideas how to fix that? btw: some datasets are working just fine.


Hi Dawid,

Check this post: TypeError: slice indices must be integers

Probably a numpy issue - I have encountered this in the past and the fixes suggested in this thread resolved it. Good luck!



Thanks a lot. Unfortunately it didn’t work. I will just use the anaconda2 backup and see if this will fix the problem.

Just in case for the future:

I tried to go back with numpy to the previous version (because this is the problem most likely, that the numpy slicing of the list has somehow changed and in the noise estimation it cannot take the list slice because it is not an integer). It shows however that numpy is proper older version but numpy base is already the newest. It finds nicely the proper location (in anaconda2 folder in cryosparc directory) but solution previously described doesn’t work.