CryoSPARC doesn't load after 4.0.3 update

The update was done without errors. I checked several things and looks fine.

$ cryosparcm checkdb
    database configuration is OK.
$ cryosparcm test i
Running installation tests...
✓ Running as cryoSPARC owner
✓ Running on master node
✓ CryoSPARC is running
✓ Connected to command_core at
✓ CRYOSPARC_LICENSE_ID environment variable is set
✓ License has correct format
✓ Insecure mode is disabled
✓ License server set to ""
✓ Connection to license server succeeded
✓ License server returned success status code 200
✓ License server returned valid JSON response
✓ License exists and is valid
✓ CryoSPARC is running v4.0.3
✓ Running the latest version of CryoSPARC
Could not get latest patch (status code 404)
✓ Patch update not required
✓ Admin user has been created
✓ Cluster connected.

$ cryosparcm status
CryoSPARC System master node installed at
Current cryoSPARC version: v4.0.3

CryoSPARC process status:

app                              RUNNING   pid 487, uptime 0:47:45
app_api                          RUNNING   pid 514, uptime 0:47:43
app_api_dev                      STOPPED   Not started
app_legacy                       STOPPED   Not started
app_legacy_dev                   STOPPED   Not started
command_core                     RUNNING   pid 390, uptime 0:48:02
command_rtp                      RUNNING   pid 430, uptime 0:47:53
command_vis                      RUNNING   pid 420, uptime 0:47:55
database                         RUNNING   pid 131036, uptime 0:48:06

License is valid

global config variables:
export CRYOSPARC_DB_PATH="/fs/project/XXX/cryomeddev/database"

But, when I access the web instance, after I login, I see the loading wheel, and it is spinning forever.
Any comment would be very helpful!


Is this an update from v3? New macOS? No projects and workspaces showing after update to v4.0 - #6 by CryoEM1

Yes, it was updated from v3. It is on RHEL 7.9. I read the post before I write this, but it was not helpful. Because I don’t see anything except the loading wheel. I attach the screen shot.

Please can you try accessing the UI via ssh port forwarding and let us know if that works?

I can try it if I must, but can you explain why do you think it has an issue on the network? It was working just fine before the update. And I can login with the GUI from the web browser. After that without any errors, I see this loading wheel, which doesn’t suggest any network issues at least for me.

I am still undecided about that, hence my request for additional datapoints.

Ah, I didn’t expect there are other information we can get from the ssh tunneling.
Sorry for my ignorance!

So, I just tried to get it with ssh port forwarding as you suggested, and now I see the GUI!
And, the GUI seems working correctly.

Then, now the problem is why it is not working without ssh tunneling. It was working fine with any browser. Should we update our firewall rules?

Thank you so much for the insightful suggestion and help!

The (partially redacted) URL in your browser screenshots suggests you might be using a reverse proxy. If that’s the case, and it happens to be an apache implementation, you may want to try what has worked for another user:

1 Like

Thank you so much for this!
Yes, this resolved our issue.