CryoSparc 2.12.4: Patch motion correction (multi) Error

Hi, I updated to CryoSparc 2.12.4, but got the same error for Patch motion correction (multi) as in CryoSparc 2.12.2. I run on CentOS. Here is the error message. Please advise.


Traceback (most recent call last):
  File "cryosparc2_compute/jobs/", line 1490, in run_with_except_hook
    run_old(*args, **kw)
  File "/home/em/Programs/CryoSparc/cryosparc2_worker/deps/anaconda/lib/python2.7/", line 754, in run
    self.__target(*self.__args, **self.__kwargs)
  File "cryosparc2_compute/jobs/", line 153, in thread_work
    work = processor.process(item)
  File "cryosparc2_worker/cryosparc2_compute/jobs/motioncorrection/", line 252, in
AssertionError: Job is not in running state - worker thread with PID 2033 terminating self.

Hi @Pei can you confirm that this is the same error as Error during patch motion correction of movies in cryosparc v2.12.4 ?

We are working to figure this out right now. Any further information you can provide would be very helpful: what was the size and number of movies, how many GPUs were you running the job on, and what is the system configuration (GPU models, CPUs, how much RAM, etc).


As far as I can tell, it was the same error as in v2.12.2. V2.11 works fine, though.

Computer configuration: CentOS 7; 2x Intel Xenon 4110 CPU; 128 GB ECC DDR4 RAM; 4x NVIDIA 2080Ti GPU; 2x 480 GB SSD; 12 TB HDD. CUDA 10.1.

1 Like

@Pei we’ve identified the bug - fix will be released asap.

Thanks! Look forward to the next release.

Hi @Pei,

We’ve released this bug in the current release- meaning there isn’t a new version number for this. In order to get the fix, you’re going to have to force-reinstall cryoSPARC (which will reinstall your cryoSPARC instance after pulling the latest version from our servers).

More info here: