Creation of admin users doesn't work (bug?)

I am trying to use the feature “add user” from the administrators menu to add a new Admin user, but it doesn’t work.
After typing the information of the user, the checkbox to introduce the information in the system is always a “cross” “X” to cancel the action, being impossible to actually add any user, no matter the information that you have typed.
Actually, it doesn’t work for adding a regular user either.
I tried both Chrome and Firefox in Ubuntu 14.04 and Windows 7.


Hi @YacobGomez, thanks for noting this, it’s a known bug to be fixed soon. Currently to create new regular users can be done via the sign up button on the login screen (after you log out). Users can be made Admin if necessary by directly modifying the database with some commands - if you need I can write up the commands for you.

Dear Ali,
thank you very much for your attention.
I would really love it if you can send me those commands. I installed the program but the computer is from another person, so she should be the administrator.
Looking forward to your reply.

Hi @YacobGomez,

The commands to make a user an administrator are:
(on the machine where cryoSPARC is running, from within the cryosparc installation directory)

eval $(cryosparc env)
mongo localhost:$CRYOSPARC_MONGO_PORT

now within the database shell:

use meteor
db.users.update({'emails.0.address':'<user email address>'},{$set:{'roles.__global_roles__.0':'admin'}})

Be sure to insert the email address that the user created their account with in the above command. The command should return a result that indicates that one record was changed.

Hope this helps,

It worked!
Thank you!