CPU only version of Extract from Micrographs needs pycuda

Hi all,

I have just tried the new “Extract from Micrographs (CPU)” on CPU node and it fails with this ironic error message:

    [CPU: 253.9 MB]  Collecting micrograph selection information...
[CPU: 255.7 MB]  Traceback (most recent call last):
  File "cryosparc_worker/cryosparc_compute/run.py", line 84, in cryosparc_compute.run.main
  File "/opt/bioxray/programs/cryosparc2/cryosparc_worker/cryosparc_compute/jobs/extract/run.py", line 99, in run_extract_micrographs_cpu_parallel
    from . import extraction_cpu_parallel as cpuextract
  File "/opt/bioxray/programs/cryosparc2/cryosparc_worker/cryosparc_compute/jobs/extract/extraction_cpu_parallel.py", line 16, in <module>
    from ...engine import cuda_core
  File "/opt/bioxray/programs/cryosparc2/cryosparc_worker/cryosparc_compute/engine/__init__.py", line 8, in <module>
    from .engine import *  # noqa
  File "cryosparc_worker/cryosparc_compute/engine/engine.py", line 9, in init cryosparc_compute.engine.engine
  File "cryosparc_worker/cryosparc_compute/engine/cuda_core.py", line 3, in init cryosparc_compute.engine.cuda_core
ModuleNotFoundError: No module named 'pycuda'

The CPU node is install with the “–nogpu” flag.


Thank you for pointing this out. We will make sure this is fixed in the next release.


A fix for this is included in v3.2, released March 29, 2021. Release notes available here: https://cryosparc.com/updates

1 Like