Continuous failure of installation

Even with “official” installation command (I changed the license # to xxx)

bash -c “$(curl -sSL”

I couldn’t install like below.
I retried many times (more than 5), still got no luck.

I wonder anyone knows how to solve this issue.

scikit-image: 0.12.3-np111py27_1
scipy: 0.18.1-np111py27_0
simplegeneric: 0.8.1-py27_1
sip: 4.18-py27_0
traitlets: 4.3.2-py27_0
wcwidth: 0.1.7-py27_0
xz: 5.2.2-1

Fetching package metadata …

CondaHTTPError: HTTP None None for url
Elapsed: None

An HTTP error occurred when trying to retrieve this URL.
HTTP errors are often intermittent, and a simple retry will get you on your way.
SSLError(SSLError(SSLError(“bad handshake: Error([(‘SSL routines’, ‘ssl3_get_server_certificate’, ‘certificate verify failed’)],)”,),),)

I ran into the same issue last night. Not sure whats the causing the problem though. The HTTPS link seems to work fine in the browser. It looks like the anaconda installer doesn’t like the new certificate for this link. ( see below)

Tweaking this line form script in the cryosparc folder worked for me.

 536: conda install -q -y --force -c fftw=3.3.4 pyfftw=0.9.2

Changing this to http did the trick for me.

May be the certificate package the anaconda installer is using needs to be updated?


Your trick worked for me as well!

For some reason, I had to recopy my modified to cryosparc folder, because after I changed the file, it was re-initialized.

Thank you very much!!

Thanks @achintangal for figuring that out.
Another way is to replace the line with:
conda install -q -y --force -c richli fftw=3.3.4 pyfftw=0.9.2

I believe this error is temporary because the certificates of the package hosting service have expired, but the above fix will be in the upcoming release.

1 Like

I see. Thanks for responding.

Confirming that I’m seeing the same issue but that this solution worked for me also.

Note that this issue is fixed in the latest version v0.4.0