Command not found when run cryosparcm restart

Hi guys,
something weird happened when i run cryosparcm restart, it shows command not found, but i still can access to web interface and the cryosparc works well. Does anyone know what is going on?
bash: cryosparcm: command not found…

If /full/path/to/cryosparc_master/bin is not inside your PATH environment variable, you may have to specify the full path to the command, like this:


where you need to replace /full/path/to with the actual location of the cryosparc_master/ directory on your computer.
[edited: linked information]

but even i run cryosparcm stop in xx/xxx/cryosparc_master/bin folder, it still shows commond not found

This is not equivalent to running


What should work inside /full/path/to/cryosparc_master/bin/:
If you are not familiar with the PATH environment variable, you may want to read an explanation of the concept like this one.

it works when i run xxx/xxx/cryosparc_master/bin/cryosparcm restart, but is there anything we can do to fix this besides reinstall? if reinstall , will i lose processed images?

You can add /full/path/to/cryosparc_master/bin permanently to your PATH, as explained in the link I posted earlier. If you need help with that, please post the outputs of these commands (under the Linux account that runs CryoSPARC processes):

echo $SHELL
ls -l ~/.*profile
cat ~/.*profile

i run this command and it looks like this below, I also try to do something like you mentioned
add export PATH=“/home/CP/cryosparc/cryosparc_master/bin/cryosparcm:$PATH” in the bashrc
but issue is same

(base) [CP@c113963 ~]$ echo $SHELL
(base) [CP@c113963 ~]$ ls -l ~/.*profile
-rw-r--r--. 1 CP CP 193 Nov 24  2021 /home/CP/.bash_profile
(base) [CP@c113963 ~]$ cat ~/.*profile
# .bash_profile

# Get the aliases and functions
if [ -f ~/.bashrc ]; then
        . ~/.bashrc

# User specific environment and startup programs


export PATH

now the situation gets worse, I can not access to web interface

The $PATH should be a list of directories that are searched by the shell for a match to a typed command, like:

export PATH="/home/CP/cryosparc/cryosparc_master/bin:$PATH"

Please post the output of the command

/home/CP/cryosparc/cryosparc_master/bin/cryosparcm status