Command Core error: Empty reply from server

closed

#1

I was having issues after trying the update to v2.4.6 so I deleted all cryosparc2 folders and removed it from my .bashrc. Got new master and worker folders and ran the install again. Everything went fine except when I try to start cryosparc I get the following:

[hansenbry@D01868462 ~]$ cryosparcm start
Starting cryoSPARC System master process…
CryoSPARC is not already running.
database: started
command_core: ERROR (spawn error)
curl: (52) Empty reply from server

I can’t seem to track down how to fix this particular error. I checked the status of cryosparc:

[hansenbry@D01868462 ~]$ cryosparcm status

CryoSPARC System master node installed at
/home/hansenbry/EMsoftware/cryosparc2-package/cryosparc2_master
Current cryoSPARC version: v2.4.6

cryosparcm process status:

command_core FATAL Exited too quickly (process log may have details)
command_proxy STOPPED Not started
command_vis STOPPED Not started
database RUNNING pid 51773, uptime 0:04:36
watchdog_dev STOPPED Not started
webapp STOPPED Not started
webapp_dev STOPPED Not started


global config variables:

export CRYOSPARC_LICENSE_ID=“56d7a1c6-de1e-11e8-95d9-e3fab6f9a34f”
export CRYOSPARC_MASTER_HOSTNAME=“D01868462.niaid.nih.gov
export CRYOSPARC_DB_PATH="/home/hansenbry/EMsoftware/cryosparc2-package/cryosparc2_database"
export CRYOSPARC_BASE_PORT=39000
export CRYOSPARC_DEVELOP=false
export CRYOSPARC_INSECURE=false

I see it suggests checking the process log, but I don’t know where that log is located. Any help is appreciated. Thanks


#2

I was able to get this SOLVED via piecing together some other posts.

This error originates from an orphaned process during the update or having multiple cryosparc installations running on the same machine. For me it was the orphaned process.

After getting a fresh install I ran ‘cryosparcm stop’ to make sure the program thought nothing was running.
Then ran ‘ps -ax | grep “supervisord”’ to see if any cryosparc processes were running. I found 1 was still there so I killed that process and when I ran ‘cryosparcm start’ the program started as before