Class2D KeyError: 'class2D_max_res_align'

Hi, I just upgraded to cryoSparc 2.12.4, but cannot run class2D with the following errors.

Traceback (most recent call last):
  File "cryosparc2_worker/cryosparc2_compute/", line 78, in
  File "cryosparc2_worker/cryosparc2_compute/jobs/class2D/", line 104, in
KeyError: 'class2D_max_res_align'

my system information:
OS: centos 7.4
CPU: Intel® Xeon® CPU E5-2637
GPU: nvidia P100 * 4

then I try to clone and repeat an old successful class2D job (successful on cryoSparc 2.11), but still fails with the same error. Any suggestion? Thanks a lot,

Best regards,

Same error here with RTX2080Ti cards. Same job could run 1 month ago with the exact parameters.

It seems that after updating, this file has been changed: /cryosparc/cryosparc2_worker/cryosparc2_compute/jobs/class2D/ and the developers added some new params. So one need to build and start a new Class2D job rather than cleaning an old one up and rebuild in order not to fail filling in all the inputs.

Hi @xzhang2017,

First try running this: cryosparcm cli "refresh_job_types()". Then, ensure you build a brand new job, instead of clearing an older one and re-queuing it as pointed out by @hxn. Please let me know if that works.

Yes, I did start a brand new Class2D job at the first place, but got the error on Class2D and cannot continue work. Actually I started a new project begining with inputing movies, everything works fine until the class2d. Then I tried to run a old class2d (also by starting a brand new class2d job by clone), but got the same error.


It’s working now after running cryosparcm cli "refresh_job_types()" and start a brand new job. Thanks a lot.