Changing SSD (no 'run' directory?)

Good morning @apunjani
I am running into an issue with trying to redirect the ssdpath. I have read previous posts mentioning a ‘run’ directory and altering the cache in the cryosparc install directory however I do not see it (See below). This is probably a simple thing but I wanted to check before modifying anything!

Also any help from anyone would be greatly appreciated!

[cryosparc_user2@c103923 CRYOSPARC]$ find -name “run”
[cryosparc_user2@c103923 CRYOSPARC]$ find -name “cache”

Hi @Kellie,

To change the configuration of a worker in cryoSPARC v2+, you can use the --update flag with cryosparcw connect.
From :

bin/cryosparcw connect
  --worker <worker_hostname>
  --master <master_hostname>
  --port <port_num>
  [--update]                       : update an existing worker configuration
  [--sshstr <custom_ssh_string>]   : custom ssh connection string like user@hostname
  [--nogpu]                        : connect worker with no GPUs
  [--gpus 0,1,2,3]                 : enable specific GPU devices only
  [--nossd]                        : connect worker with no SSD
  [--ssdpath <ssd_path> ]          : path to directory on local ssd
  [--ssdquota <ssd_quota_mb> ]     : quota of how much SSD space to use (MB)
  [--ssdreserve <ssd_reserve_mb> ] : minimum free space to leave on SSD (MB)
  [--lane <lane_name>]             : name of lane to add worker to
  [--newlane]                      : force creation of a new lane if specified lane does not exist

In your case, you can use the command
bin/cryosparcw connect --worker <worker_hostname> -- master <master_hostname> --port <port_num> --update --ssdpath <ssd_path>

That worked perfectly thank you very much!

Thanks again,

Is this still the same process for V4?


Hi @mjmcleod64,

Yes, this process hasn’t changed since v2.