Change hostname for cryosparc V2 worker

closed

(Chen Zhao) #1

Originally, the hostname of our workstation is not mapped to its IP address. Therefore when I installed cryosparc V2 on that workstation, I had to manually change the install.sh to force cryosparc to take the IP address instead of the hostname. Now the IT department assigned us a different IP address associated with a new hostname. How am I supposed to change the host name? The following is what I have tried and failed:

  1. I modified the hostname in config.sh (also changed install.sh back to its original form but this probably does not matter)
  2. I ran install.sh again. The script finished within 1 minute without any error, but I cannot start cryosparc.
  3. I also ran cryosparcm update, the master was updated to V2.9.0 correctly but the worker failed because it has the wrong host name.
  4. Nevertheless, I manually updated the worker as instructed but of course it did not work.
  5. I then tried to reconnect the worker with the master with 2 different methods:
    ./cryosparcw connect --worker new_host_name --master new_host_name
    Or
    ./cryosparcw connect --worker old_host_name --master new_host_name
    But I guess because the old host name is not valid anymore, none of these two worked. And the error I got is:
    client.py: command (new_host_name:39002/api) did not reply within timeout of 300 seconds

So I guess if I can manually change the hostname of cryosparc worker, it might work out. Could anyone inform me how to do this?

However, I have another line of evidence suggesting that even the master does not talk with the hostname correctly. This is because now when I run cryosparcm update, it cannot connect to the internet and the .tar.gz files have size 0.

Based on everything I observe, I really appreciate if someone could give me any suggestions. Also, if I reinstall cryosparc V2 completely from scratch, will I lose the history of my projects and workspaces?

Thanks a lot again!


(Stephan Arulthasan) #2

Hi @chenzhao,

First, I’d like to point you to our cryoSPARC Migration Tutorial.

Once you complete the migration of your master node (the final step in the tutorial), you should be able to connect a new worker node using the new hostname.

You can reinstall cryoSPARC from scratch by deleting the cryosparc2_master and cryosparc2_worker folders after ensuring cryoSPARC is completely turned off. Just make sure you don’t delete your database or project folder directories.


(Chen Zhao) #3

Thank you for the advice! Finally I just reinstalled from scratch and figured it is probably the easiest solution…