Centos8 undefined symbol: EVP_KDF_ctrl

Installing version 3.0.0 installation stalls

Starting cryoSPARC System master process..
CryoSPARC is not already running.
database: started
command_core: started
curl: symbol lookup error: /lib64/libk5crypto.so.3: undefined symbol: EVP_KDF_ctrl, version OPENSSL_1_1_1b

Last line keeps spamming over and over…

I had this issue on CentOS 8 as well. I got around it by backing up and removing all the libcrypto.so* files in the cryosparc directory.

I have the same problem, both when doing the upgrade from v2.15 and a clean installation.

Can you explain your solution in more details, please? These files seem to come with conda packages, so it does not seem safe to simply delete them and could have unintended side effects.

I am wondering if updating curl could work, since I see the system package manager lists a new version for it. I will try that when I have time.

I tried a fresh installation of cryoSPARC v3 after I updated curl, but I still got this same curl: symbol lookup error.

Hi @Guillaume,

Sorry for the inconvenience. We’ll most likely release a patch for this bug soon, but in the mean time, this is what another one of our users did to get around it:

I had to install the openssl-devel package and its dependencies, and then remove all the ‘libcrypto.so.1.1’ files with ‘find -name “libcrypto.so.1.1” -delete -print’.

1 Like


I just wanted to report that a fresh installation of version 3.1 worked fine, I did not get this curl error this time.