Can't start after update to 2.8

issue_recorded

#21

I’m getting the same problem. First the supervisorctl problem, and then the import error:

DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7.
Processing ./deps_bundle/python/python_packages/pip_packages/Flask-JSONRPC-0.3.1.tar.gz
Processing ./deps_bundle/python/python_packages/pip_packages/Flask-PyMongo-0.5.1.tar.gz
Processing ./deps_bundle/python/python_packages/pip_packages/libtiff-0.4.2.tar.gz
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File “”, line 1, in
File “/tmp/pip-req-build-WHbEHQ/setup.py”, line 77, in
from numpy.distutils.core import setup, Extension
ImportError: No module named numpy.distutils.core

----------------------------------------

Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-req-build-WHbEHQ/

Done.
pip packages installation successful.

Main dependency installation completed. Continuing…

Completed.
Currently checking hash for mongodb
Forcing reinstall for dependency mongodb…

mongodb 3.4.10 installation successful.

Completed.
Completed dependency check.

I’m using ubuntu 18.04


#22

by the way, reading carefully through the different traces, the first thing to fail is the “Verifying transaction: failed”
and then for some reason it tries to install anaconda2 into my home directory, even though I’m logged in as cryosparc_user:

CondaMultiError: EnvironmentNotWritableError: The current user does not have write permissions to the target environment.
environment location: /home/ekellogg/anaconda2
uid: 998
gid: 998

This seems to be the beginning of the problems. but I can’t figure out why it’s trying to write to my home directory when I’m logged in as cryosparc_user


#23

I found the cause for my problem: I have another anaconda installation on this computer. I removed it from my PATH variable and than the force dependencies worked.


#24

You’re right! It was due to my own installation of conda. Removing it from my path and then doing the force dependencies worked


#25

Hi @david.haselbach and @ekellogg :smile: Confirmed here also, when working in a shell that doesn’t see the local installation of anaconda I was able to do a fresh install and no longer get the ‘supervisor==3.3.5’ related error on starting the master. For me the cryosparc worker forcedeps method inside this same shell did not work and I needed to reinstall fresh.

@sarulthasan, note that during installation when answering 2 (No) to the download test data question, on my system the test data is still downloaded.


#26

Hi @kylelmorris,

Thank you for reporting! We’ve fixed this bug and it’ll be released in the next patch.


#27

Hello,

I am having a similar issue, but I do not have a local install of conda. I am unable to call the command forcedeps, it is an “Unknown command”. I may be missing something.

Here is my error when I run cryosparcm status, cryosparcm update and cryosparcm stop:

Traceback (most recent call last):
  File "/data/cryosparc/cryosparc2_master/deps/anaconda/bin/supervisorctl", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/data/cryosparc/cryosparc2_master/deps/anaconda/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3241, in <module>
    @_call_aside
  File "/data/cryosparc/cryosparc2_master/deps/anaconda/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3225, in _call_aside
    f(*args, **kwargs)
  File "/data/cryosparc/cryosparc2_master/deps/anaconda/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3254, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/data/cryosparc/cryosparc2_master/deps/anaconda/lib/python3.7/site-packages/pkg_resources/__init__.py", line 583, in _build_master
    ws.require(__requires__)
  File "/data/cryosparc/cryosparc2_master/deps/anaconda/lib/python3.7/site-packages/pkg_resources/__init__.py", line 900, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/data/cryosparc/cryosparc2_master/deps/anaconda/lib/python3.7/site-packages/pkg_resources/__init__.py", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'supervisor==3.3.3' distribution was not found and is required by the applicationTraceback (most recent call last):
  File "/data/cryosparc/cryosparc2_master/deps/anaconda/bin/supervisorctl", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/data/cryosparc/cryosparc2_master/deps/anaconda/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3241, in <module>
    @_call_aside
  File "/data/cryosparc/cryosparc2_master/deps/anaconda/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3225, in _call_aside
    f(*args, **kwargs)
  File "/data/cryosparc/cryosparc2_master/deps/anaconda/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3254, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/data/cryosparc/cryosparc2_master/deps/anaconda/lib/python3.7/site-packages/pkg_resources/__init__.py", line 583, in _build_master
    ws.require(__requires__)
  File "/data/cryosparc/cryosparc2_master/deps/anaconda/lib/python3.7/site-packages/pkg_resources/__init__.py", line 900, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/data/cryosparc/cryosparc2_master/deps/anaconda/lib/python3.7/site-packages/pkg_resources/__init__.py", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'supervisor==3.3.3' distribution was not found and is required by the application

I am not sure when cryoSPARC broke as I have not used it for about a month. I did have some python version issues when installing another program IHRSR. I thought I had resolved this issue, but cannot rule it out as the problem. I am still running v2.4.6 and cannot update.

Any help would be appreciated. I have not tried a fresh install yet.


#28

Hi @Kristy,

I’m not sure how the wrong dependencies were installed into the cryoSPARC folder, but running the override commands found here: https://cryosparc.com/docs/reference/install/#forced-update will most likely resolve your issues.


#29

Hello, thanks for the help, @sarulthasan.

When I try cryosparcm update --override I get an error: Improper usage. I can use --list and --version without trouble, but not --override.

Should I move this to a different thread? I started here as the issue seems to be similar, but not directly related to a problem after an update to 2.8.

Edited:
When I checked the supervisord path using
eval $(cryosparcm env)
which supervisord
which supervisorctl

They both reported the correct path, but when I checked supervisord --version the same error string was printed that I posted in my earlier post ending with “DistributionNotFound: The ‘supervisor==3.3.3’ distribution was not found and is required by the application”

I can confirm supervisor-3.3.3 is in the anaconda/pkgs


#30

So I finally just deleted the cryosparc master directory and did a new installation. It seems to be working again.