Can't retrieve download

Problem with attempting to download cryosparc. I’ve seen this post before, but could not find the solution.

Thanks. N.

[* cryosparc]$ pwd


[* cryosparc]$ export LICENSE_ID="my license"

[* cryosparc]$ sudo curl -L$LICENSE_ID > cryosparc2_master.tar.gz

-bash: cryosparc2_master.tar.gz: Permission denied

hey @mwaxham,

Is it possible if you can run the command without sudo ?

Yep, tried that first, same permission denied error.

Is there a command that can be run to check the license is active?

Hi @mwaxham,

Please see this post:


I do not seem to be able to export the license I received so that the downloads will work properly. I download empty directories.

This is the command I used and there is no install file written to the directory:
export LICENSE_ID=“<[redacted]>”

Also tried removing the <> and finally removing the “”, none of these wrote out a file.

I did receive this license on January

Your request for a non-commercial license for CryoSPARC™ has been approved!

Your license ID is: [redacted]

Any thoughts? A silly place to get hungup…

@mwaxham Please

  1. define the LICENSE_ID variable omitting the < and > signs
    curl -L$LICENSE_ID -o cryosparc_master.tar.gz
    curl -L$LICENSE_ID -o cryosparc_worker.tar.gz
  2. do not post confidential information, like your license id, on the forum

This let me download the tar files and I could successfully untar them in the cryosparc directory. When I cd to the master and try to run the ./install command I get and error that it cannot find the license. There was also on license file written when I ran the export license_ID=“” command in the parent directory.

@mwaxham Please can you copy and paste from your terminal

  • the download
  • the

commands you used.

Sorry, i saw an issue and ran the commands and the install seemed to complete, answering yes to the questions. There is a cryosparc_database folder now in the cryosparc folder. There were no errors reported, but unfortunately I closed the terminal before copying the information that ran during the install.
If I understand the install directions on the web, I should be good to go, but the cryosparcm start command is not recognized. I get cryosparc_user@computer name:~$ cryosparcm start
cryosparcm: command not found.

It also does not appear that the .bashrc file has any pointers to cryosparc items, despite answering yes to that query.

One more follow up. Tunneled into the /home/cryosparc_user/cryosparc/cryosparc_master/bin directory and tried running the cyrosparcm restart command from there and no luck.

Just a ping, don’t know if you’re waiting on me for more information? If you think it worthwhile I can delete everything and start over so I have the installation log. If so, let me know if there is a “proper” uninstall protocol.

Thanks. Neal.

Hi, tried uninstalling and reinstalling. Most seemed successful, but did not go to completion. Full terminal output is pasted below (redacted).

cryosparc_user@neal-B7105F48TV4HR-2T-N:~/cryosparc/cryosparc_master$ ./ --standalone
–license $LICENSE_ID
–worker_path /home/cryosparc_user/cryosparc/cryosparc_worker
–ssdpath /media/cryosparc_user/nealssd/cryosparc_cache
–initial_email “”
–initial_password “cryosparc”
–initial_username “cryosparc”
–initial_firstname “Neal”
–initial_lastname “Waxham”
–port 61000


Installation Settings:
License ID : redacted
Root Directory : /home/cryosparc_user/cryosparc/cryosparc_master
Master Hostname : neal-B7105F48TV4HR-2T-N
Database Directory : /home/cryosparc_user/cryosparc/cryosparc_database
Base HTTP Port Number : 61000
Developer Install : false
Operating System : Linux
Insecure Install : false
Standalone Install : true
Worker Root Directory : /home/cryosparc_user/cryosparc/cryosparc_worker
Initial User Email : redacted
Initial User Name : cryosparc
Initial First Name : Neal
Initial Last Name : redacted
SSD : true
SSD Path : /media/cryosparc_user/nealssd/cryosparc_cache
Version : v4.4.1

The CryoSPARC System master installation will host a database,
web application, and command layer for CryoSPARC, but will not
perform processing jobs.

Please read and confirm the above settings. The CryoSPARC database
will be stored at the database directory which is relative to the
root directory, unless provided as an absolute path.
You can change the database directory now by passing the --dbapth
parameter to this installer, or later via the command line.

Are the above settings correct?

  1. Yes
  2. No
    #? 1

Setting up hard-coded environment variables

Installing all dependencies.

Warning: conda environment not found; this indicates that a cryoSPARC installation is either incomplete or in progress
Checking dependencies…
Dependencies for python have changed - reinstalling…

Installing anaconda python…

Unpacking payload …
Collecting package metadata (current_repodata.json): done
Solving environment: done

Package Plan

environment location: /home/cryosparc_user/cryosparc/cryosparc_master/deps/anaconda

added / updated specs:
- _libgcc_mutex==0.1=main
- _openmp_mutex==4.5=1_gnu
- brotlipy==0.7.0=py38h27cfd23_1003
- ca-certificates==2022.3.29=h06a4308_1
- certifi==2021.10.8=py38h06a4308_2
- cffi==1.15.0=py38hd667e15_1
- charset-normalizer==2.0.4=pyhd3eb1b0_0
- colorama==0.4.4=pyhd3eb1b0_0
- conda-content-trust==0.1.1=pyhd3eb1b0_0
- conda-package-handling==1.8.1=py38h7f8727e_0
- conda==4.12.0=py38h06a4308_0
- cryptography==36.0.0=py38h9ce1e76_0
- idna==3.3=pyhd3eb1b0_0
- ld_impl_linux-64==2.35.1=h7274673_9
- libffi==3.3=he6710b0_2
- libgcc-ng==9.3.0=h5101ec6_17
- libgomp==9.3.0=h5101ec6_17
- libstdcxx-ng==9.3.0=hd4cf53a_17
- ncurses==6.3=h7f8727e_2
- openssl==1.1.1n=h7f8727e_0
- pip==21.2.4=py38h06a4308_0
- pycosat==0.6.3=py38h7b6447c_1
- pycparser==2.21=pyhd3eb1b0_0
- pyopenssl==22.0.0=pyhd3eb1b0_0
- pysocks==1.7.1=py38h06a4308_0
- python==3.8.13=h12debd9_0
- readline==8.1.2=h7f8727e_1
- requests==2.27.1=pyhd3eb1b0_0
- ruamel_yaml==0.15.100=py38h27cfd23_0
- setuptools==61.2.0=py38h06a4308_0
- six==1.16.0=pyhd3eb1b0_1
- sqlite==3.38.2=hc218d9a_0
- tk==8.6.11=h1ccaba5_0
- tqdm==4.63.0=pyhd3eb1b0_0
- urllib3==1.26.8=pyhd3eb1b0_0
- wheel==0.37.1=pyhd3eb1b0_0
- xz==5.2.5=h7b6447c_0
- yaml==0.2.5=h7b6447c_0
- zlib==1.2.12=h7f8727e_1

The following NEW packages will be INSTALLED:

_libgcc_mutex pkgs/main/linux-64::_libgcc_mutex-0.1-main
_openmp_mutex pkgs/main/linux-64::_openmp_mutex-4.5-1_gnu
brotlipy pkgs/main/linux-64::brotlipy-0.7.0-py38h27cfd23_1003
ca-certificates pkgs/main/linux-64::ca-certificates-2022.3.29-h06a4308_1
certifi pkgs/main/linux-64::certifi-2021.10.8-py38h06a4308_2
cffi pkgs/main/linux-64::cffi-1.15.0-py38hd667e15_1
charset-normalizer pkgs/main/noarch::charset-normalizer-2.0.4-pyhd3eb1b0_0
colorama pkgs/main/noarch::colorama-0.4.4-pyhd3eb1b0_0
conda pkgs/main/linux-64::conda-4.12.0-py38h06a4308_0
conda-content-tru~ pkgs/main/noarch::conda-content-trust-0.1.1-pyhd3eb1b0_0
conda-package-han~ pkgs/main/linux-64::conda-package-handling-1.8.1-py38h7f8727e_0
cryptography pkgs/main/linux-64::cryptography-36.0.0-py38h9ce1e76_0
idna pkgs/main/noarch::idna-3.3-pyhd3eb1b0_0
ld_impl_linux-64 pkgs/main/linux-64::ld_impl_linux-64-2.35.1-h7274673_9
libffi pkgs/main/linux-64::libffi-3.3-he6710b0_2
libgcc-ng pkgs/main/linux-64::libgcc-ng-9.3.0-h5101ec6_17
libgomp pkgs/main/linux-64::libgomp-9.3.0-h5101ec6_17
libstdcxx-ng pkgs/main/linux-64::libstdcxx-ng-9.3.0-hd4cf53a_17
ncurses pkgs/main/linux-64::ncurses-6.3-h7f8727e_2
openssl pkgs/main/linux-64::openssl-1.1.1n-h7f8727e_0
pip pkgs/main/linux-64::pip-21.2.4-py38h06a4308_0
pycosat pkgs/main/linux-64::pycosat-0.6.3-py38h7b6447c_1
pycparser pkgs/main/noarch::pycparser-2.21-pyhd3eb1b0_0
pyopenssl pkgs/main/noarch::pyopenssl-22.0.0-pyhd3eb1b0_0
pysocks pkgs/main/linux-64::pysocks-1.7.1-py38h06a4308_0
python pkgs/main/linux-64::python-3.8.13-h12debd9_0
readline pkgs/main/linux-64::readline-8.1.2-h7f8727e_1
requests pkgs/main/noarch::requests-2.27.1-pyhd3eb1b0_0
ruamel_yaml pkgs/main/linux-64::ruamel_yaml-0.15.100-py38h27cfd23_0
setuptools pkgs/main/linux-64::setuptools-61.2.0-py38h06a4308_0
six pkgs/main/noarch::six-1.16.0-pyhd3eb1b0_1
sqlite pkgs/main/linux-64::sqlite-3.38.2-hc218d9a_0
tk pkgs/main/linux-64::tk-8.6.11-h1ccaba5_0
tqdm pkgs/main/noarch::tqdm-4.63.0-pyhd3eb1b0_0
urllib3 pkgs/main/noarch::urllib3-1.26.8-pyhd3eb1b0_0
wheel pkgs/main/noarch::wheel-0.37.1-pyhd3eb1b0_0
xz pkgs/main/linux-64::xz-5.2.5-h7b6447c_0
yaml pkgs/main/linux-64::yaml-0.2.5-h7b6447c_0
zlib pkgs/main/linux-64::zlib-1.2.12-h7f8727e_1

Preparing transaction: done
Executing transaction: done
installation finished.

anaconda python installation successful.

Extracting all conda packages…

conda packages installation successful.

Main dependency installation completed. Continuing…

Currently checking hash for mongodb
Dependencies for mongodb have changed - reinstalling…

mongodb 3.6.23 installation successful.

Completed dependency check.


CryoSPARC System master has now been installed.
Add bin directory to your ~/.bashrc ?

  1. Yes
  2. No
    #? 1
    cryosparc bin directory already in PATH, skipped.


The installer will now download, install and connect the worker
package on this machine. The worker package will allow CryoSPARC
to run compute jobs.

Starting CryoSPARC…

Starting cryoSPARC System master process…
CryoSPARC is already running.
If you would like to restart, use cryosparcm restart

Creating the initial CryoSPARC user…

Creating user cryosparc with email: and name: Neal Waxham
*** (http://neal-B7105F48TV4HR-2T-N:61002, code 400) Encountered ServerError from JSONRPC function “create_user” with params (‘initial’, 'xxxxxx, ‘xxxxxx’, ‘xxxxxx’, ‘xxxx’, ‘xxxx’):
ServerError: neal-b7105f48tv4hr-2t-n:61001: [Errno 111] Connection refused, Timeout: 30s, Topology Description: <TopologyDescription id: 65cb868b6cad2d6a39fff20c, topology_type: Single, servers: [<ServerDescription (‘neal-b7105f48tv4hr-2t-n’, 61001) server_type: Unknown, rtt: None, error=AutoReconnect(‘neal-b7105f48tv4hr-2t-n:61001: [Errno 111] Connection refused’)>]>
Traceback (most recent call last):
File “/home/cryosparc_user/cryosparc/cryosparc_master/cryosparc_command/”, line 195, in wrapper
res = func(*args, **kwargs)
File “/home/cryosparc_user/cryosparc/cryosparc_master/cryosparc_command/command_core/”, line 821, in create_user
users = list(mongo.db[‘users’].find())
File “/home/cryosparc_user/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.8/site-packages/pymongo/”, line 1280, in next
if len(self.__data) or self._refresh():
File “/home/cryosparc_user/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.8/site-packages/pymongo/”, line 1165, in _refresh
self.__session = self.__collection.database.client._ensure_session()
File “/home/cryosparc_user/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.8/site-packages/pymongo/”, line 2027, in _ensure_session
return self.__start_session(True, causal_consistency=False)
File “/home/cryosparc_user/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.8/site-packages/pymongo/”, line 1976, in __start_session
server_session = self._get_server_session()
File “/home/cryosparc_user/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.8/site-packages/pymongo/”, line 2013, in _get_server_session
return self._topology.get_server_session()
File “/home/cryosparc_user/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.8/site-packages/pymongo/”, line 525, in get_server_session
session_timeout = self._check_session_support()
File “/home/cryosparc_user/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.8/site-packages/pymongo/”, line 507, in _check_session_support
File “/home/cryosparc_user/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.8/site-packages/pymongo/”, line 226, in _select_servers_loop
raise ServerSelectionTimeoutError(
pymongo.errors.ServerSelectionTimeoutError: neal-b7105f48tv4hr-2t-n:61001: [Errno 111] Connection refused, Timeout: 30s, Topology Description: <TopologyDescription id: 65cb868b6cad2d6a39fff20c, topology_type: Single, servers: [<ServerDescription (‘neal-b7105f48tv4hr-2t-n’, 61001) server_type: Unknown, rtt: None, error=AutoReconnect(‘neal-b7105f48tv4hr-2t-n:61001: [Errno 111] Connection refused’)>]>

I suspect that there were some left-over CryoSPARC processes (from a previous installation attempt). Before attempting installation again, please check for and terminate unwanted processes.
Does this help?

So, success, I believe. I can use http://localhost:61000/ to activate the web interface, however, none of the cryosparcm commands are available in the terminal after closing and relaunching a fresh terminal.

I would also like to reload my previous database into this new version. But, I don’t want to do that until I can control cryosparc with the cryosparcm commands.

Hope with one or two more exchanges I will not have to bother you again.

P.S. you mentioned memory issues with the 2080 GPU, I have a 3090 coming. Will i have to reinstall or run some update to have cryosparc access the new card?

If your shell is bash, you can make cryosparcm available in new shells by including a line like


in your /home/cryosparc_user/.bashrc file. But according to

a similar line should already exist.
cryosparcm commands should not be run by users other than the designated Linux user, cryosparc_user in your case.

There are kill commands that I had to use to exit the hung jobs that never cleared during previous failed installs. I used the scary “kill -15 -1” to terminate all running programs which logged me out in an abrupt way, but did clear all the hung jobs.

What I would now like to do is reload the database I exported before upgrading. Can you tell me how to do this?

What command did you use to “export” the database?