Can't access webserver from other computers on the network


I can’t pinpoint exactly when this happened, but I can no longer access cryoSPARC web server from other computers on the network. Port 38000 is open and web server works fine on localhost. I tried restarting the system - still the same issue.


Hi Mike,

Sorry to hear about this trouble. As far as I can see, there have not been any code changes in cryoSPARC that are related to networking or webserver access. Unfortunately I can’t be of much help… we haven’t seen a problem like this in our dev instances or any others.

If there are any other clues we can help troubleshoot further.


Hi Ali,

I did an update to the version 0.3.9 through the browser button as soon as it was released and I believe that’s when it stopped working (it might have been one update back though - 0.3.6 which I also did through the browser). I have just ran $cryosparc update from command line. See the output below where it says updated from 0.3.9 to 0.3.9. Now remote connections work fine!

$ cryosparc update
CryoSPARC update starting on Wed Mar 29 18:10:18 EDT 2017

No version specified - updating to latest version.

Updating to version v0.3.9.

Stopping cryoSPARC…
mongod: stopped
webapp: stopped
Shut down
Downloading update…

Deleting old files…
npm WARN package.json meteor-dev-bundle@0.0.0 No description
npm WARN package.json meteor-dev-bundle@0.0.0 No repository field.
npm WARN package.json meteor-dev-bundle@0.0.0 No README data
npm WARN package.json meteor-dev-bundle@0.0.0 No license field.
node-pre-gyp ERR! Tried to download(404):
node-pre-gyp ERR! Pre-built binaries not found for bcrypt@1.0.2 and node@4.6.2 (node-v46 ABI) (falling back to source compile with node-gyp)

Successfully updated from version v0.3.9 to version v0.3.9.

Starting cryoSPARC…
mongod: started
webapp: started

CryoSPARC started.
From this machine, access at
From other machines on the network, access at

Startup can take several minutes. Point your browser to the address
and refresh until you see the cryoSPARC dashboard.


Hi @apunjani ,
I have the same problem: cryosparc starts smoothly, but web app doesn’t work.
I tried to update cryosparc as @MikeK did, but it didn’t work.

I have also tried what’s suggested in the guide here:

But again it doesn’t work.

Any clue?