Cache quota problem

Hello cryosparc community!

I’ve tried changing the cache quota to ~120GB, but get the same error:

"Cache full, deleting old files. Free: 42620.83 MB Requested: 59126.60 MB

WARNING: SSD full or other jobs running: cannot free required 59126.60MB

Waiting 30 seconds for other jobs to finish, then retrying"

Is this something with an obvious fix?

Much appreciated for any help!

Hi @t.laughlin,

How large is your SSD, and are you sure there is actually more than 42620 MB of (free) space on it, not counting the cryosparc cache? cryosparc will clear out its own cache of other data to make space for the currently running job(s). You can check space on the SSD by:
df -h
shows the available and used space on each mounted drive.

And you can see how much of the SSD cryosparc is actually using currently by going into the cryosparc/run/cache directory and executing
du -hs

Also note that if you want to completely nuke the cryoSPARC cache and have it start clean, you can just

cd cryosparc/run/cache
rm -rf *

where cryosparc is your cryosparc installation directory.

:grinning: Thank you for the quit response and help!