Blob picker missing highest contrast particles (negative stain)

When we process negative stain data, importing with the negative stain flag on, the blob picker seems to pick around the particles, missing most of them.

It seems like this has been reported before:

Was there a resolution to this issue? What is the recommended workflow for processing negative stain data in cryosparc?

Cheers
Oli

After Inspect picks, it is clearly picking some particles, and it seems to me that the ones it is missing are those with the highest contrast. Perhaps there are some automatic exclusions based on the local power that are being applied behind the scenes, which are appropriate for cryo but not for negative stain? This is with the upper power threshold set to the maximum value:

Oli, does it work if you just flip the micrographs first, e.g. e2proc2d.py --mult=-1 ... ?

I’ve always found cryoSPARC to work perfectly with negative stain data, if I just flip the micrographs first…

I have not tried that but will give it a go, thanks @DanielAsarnow!

Hi @olibclarke, when you have a chance, please let us know if flipping the micrographs per @DanielAsarnow’s suggestion, fixed this for you

Hi @spunjani - I will certainly try this and I am sure it will work, but this is a workaround - if the “negative stain” mode at micrograph import doesn’t work, it should be fixed or removed, I think.

Hi @olibclarke @DanielAsarnow we’ll triple check that we don’t have a missing negative sign

Btw on some negative stain data I found that setting the Lowpass filter in picking (blob or template) to low resolutions (eg. 120A) helped to some degree

1 Like

Hi @apunjani, to me it seems to be an issue of some kind of contrast threshold, not a missing negative sign - because it is correctly picking some of the particles, just missing those with the highest contrast, as far as I can tell. Whereas if I import NS data as cryo, it picks around the particles and doesn’t pick any negatively stained particles at all.

Cheers
Oli