Attempting standalone installation on hpc, error "unknown option: --license"

Hi there,

I am a bit new to this, so bear with me.

I am ssh-tunneling remotely into our hpc computing service and attempting to install a standalone installation there. I have confirmed with the hpc admin that this installation should, theoretically, work. Based on “lsb_release -a” the hpc is running Linux 7.9 (Nitrogen).

I am following the standalone installation according to ( Regardless of code input strategy, i.e. line-by-line with “” at the end of each line, or without “” at the end of each line, or by running each line separately, I get the same error: “unknown option --license”.

“echo $LICENSE_ID” yields my license number back to me showing that the “export LICENSE_ID=”<license_id>" seems to have worked and, similarly, “curl” yields “{“message”:“Missing Authentication Token”}” again indicating license is correct/active.

Any advice?

Update: if I instead input it without using “” at all, as follows:

./ --standalone --license $LICENSE_ID --worker_path <workerpath/cryosparc2_worker> --cudapath <cuda_path> --ssdpath <ssd_path> --initial_email “” --initial_password test123 --initial_name “EvO”

I get the error:

“ping: socket: operation not permitted”
“Error: could not ping”

Which sounds more like an hpc/remote access problem, possibly?

Hi evo, same for me, I am not a Linux expert, so … from your question it is not clear, are you replacing the information between < > by the real situation or not? For instance <cuda_path> shoud actually be the location of your cuda installation, without <> and without “”. The same for the cryosparc2 worker directory and the ssd mounting point. It’s been a while since I installed Cryosparc2, but from my memory there were no “” anywhere - not even in my email address.
The best is to have someone who knows Linux to help you out. After the installation you’ll need to set up a simple web server in the destination machine. Not very difficult to do, but I needed to google it and spend some time trying.

By the way, for the geeks who might eventually see this, I am using a Mac connecting to our Linux server running CryoSparc2.15. I can not start with ‘cryosparcm start’ by ssh (for information ssh -X doesn’t work with Macs). I need to start the remote desktop program Nomachine, login, open a remote terminal and type ‘cryosparcm start’. Then it just works with no error messages. I can close the Nomachine connection and keep cryosparcking. Not worth starting a new trend for this, but just for you to know.

Hi Carlos,

I am discovering I am not only new to cryosparc but apparently forum posting, as well! I was attempting to input the backspace symbol in my quotation marks in the post above, but these were apparently lost in upon posting. In other words, my error message differed depending on if I included backspace, as suggested in the quick installation guide (see attached image). Sorry for the confusion.

My error message differed depending on if I includede them or not. Without including backspaces, and instead writing the entire code on one line, I received the “ping: socket:” error.

As for your questions, I am replacing the placeholder information with my cuda location, directories, email etc. yes.

Thank you for your suggestion. I spoke with our hpc staff and they suggested commenting out lines 182-185 in the installation file, as these seem to be responsible for my error. I will try this tomorrow and get back to you.


Allright, so after removing all backspaces from the code, as well as quotation marks as suggested by Carlos (still used single quotation mark ’ for my initial_name, as it contains spaces), and removing lines 182-185 from the as suggested by my hpc admin (using vim, :182,185d and :wq) the installation was a success!