AssertionError during CTF Refinement job: Says ctf/cs_mm is not constant and that it should be a value I never inputted


While runing a Global CTF Refinement (BETA) job with outputs coming from a Non-uniform Refinement (NEW!) I ran into this AssertionError. It says my cs_mm should be 3.1690547 but I never inputted that value, I actually put 2.7 mm.

I had run this job before and it went throiugh with no problems, but then I re-extracted my particles with a bigger box size, ran them through Non-uniform Refinement and then into this job and now it doesn’t work.

I’ve tried messing with the parameters but alas, it still fails.

Does somebody know a fix for this?



Probably you have refinement of global CTF parameters selected in non uniform? That would explain why it is 3.17, but not why it is not constant - are you inputting particles from multiple jobs?


Hi Oli,

I did.

However, I just tried doing the same job, with the same patameters, with the outputs of a single Homogenous refinement job that had particles straight from an extraction job and it gave the same error.