Anaconda installation error

open

#1

Hello,

We were trying to do a fresh installation of cryosparc_master. Then we got this problem:

DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7.
Processing ./deps_bundle/python/python_packages/pip_packages/Flask-JSONRPC-0.3.1.tar.gz
Processing ./deps_bundle/python/python_packages/pip_packages/Flask-PyMongo-0.5.1.tar.gz
Processing ./deps_bundle/python/python_packages/pip_packages/libtiff-0.4.2.tar.gz
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File “”, line 1, in
File “/tmp/pip-req-build-2xAjNl/setup.py”, line 77, in
from numpy.distutils.core import setup, Extension
ImportError: No module named numpy.distutils.core

----------------------------------------

Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-req-build-2xAjNl/

Done.
pip packages installation successful.

Main dependency installation completed. Continuing…

The resulting cryosparc_master installation does not seem to be functional. For example, if I type “cryosparcm creatuser --email …”, I got an error:

"Traceback (most recent call last):
File “/home/cryosparc_user/software/cryosparc/cryosparc2_master/deps/anaconda/lib/python2.7/runpy.py”, line 174, in _run_module_as_main
main”, fname, loader, pkg_name)
File “/home/cryosparc_user/software/cryosparc/cryosparc2_master/deps/anaconda/lib/python2.7/runpy.py”, line 72, in _run_code
exec code in run_globals
File “/home/cryosparc_user/software/cryosparc/cryosparc2_master/cryosparc2_compute/client.py”, line 12, in
import numpy as n
ImportError: No module named numpy

By the way, since Python2 is officially deprecated, is there a plan to move to python 3?

Zhijie