Ab-initio failed at initial step in v2.13

closed

#1

Hi,

I have a problem in Ab-initio reconstruction. Every time I set it up I end up with an error eg:

Traceback (most recent call last):
File “cryosparc2_worker/cryosparc2_compute/run.py”, line 78, in cryosparc2_compute.run.main
File “cryosparc2_worker/cryosparc2_compute/jobs/abinit/run.py”, line 385, in cryosparc2_compute.jobs.abinit.run.run_homo_abinit
File “cryosparc2_compute/dataset.py”, line 379, in subset_idxs
newdata[field] = self.data[field][keep_idxs]
ValueError: could not broadcast input array from shape (14) into shape (90)

There is no matter if I have large or smaller box size, If I change batch size, resolution limits or imposed symmetry.
Anyone had this problem before with this particular task??

best
AB


#2

I get the same error with both heterogeneous refinement and ab initio since the new upgrade to v2.13. The shape (##) will vary.


#3

Hi @ArturB, @Navid,

Thanks for reporting this bug. It looks like an issue with only multi-class ab-initio and heterogeneous refinement. We have released an update to cryoSPARC that fixes the issues you’re having (v2.13.2, January 30, 2020).

To update, run: cryosparcm update


#4

Thanks @sarulthasan

now it works fine. please mark topic as solved

best
ab