3DVA pauses at batch 1 for iteration 0 when "Number of modes to solve" = 20

Hi, I am doing 3DVA with “Number of modes to solve”=20, but the job is pausing at batch 1 for iteration 0 (see the following log). When I was doing 3DVA with “Number of modes to solve”=6 for the same dataset (other parameters are the same), it run fine. Any suggestions? Thanks!


Starting 3D Variability =====================
[CPU: 10.21 GB] Initial reconstruction 1 of 2
[CPU: 10.75 GB] batch 7426 of 7426
Start iteration 0 of 20
[CPU: 14.37 GB] batch 1 of 7426

I don’t think there is any utility in having more than 3-5 modes. Each mode here is a separate principle component and there are likely not that many sources of motion that can be accounted for. If what you are looking for is more classes at the end, this is a different parameter.

I would suggest: 3DVA 3 modes 8Å resolution, then 3DVA linear 6Å 10-30 classes (for 200k particles do 10 classes). ALSO 3DVA cluster 6Å 10-30 classes, again selecting a value with ~20k particles in each class expected. Then run refinements on good looking classes based on volume shape and 3D slices.

These are total random guess parameters since I have no info about your data. But I would also suggest reading the online info about the job type.

It’s also possible you are an extremely advanced user and your question was neither intended for me nor answered by me :joy:

1 Like

Thanks for your suggestions.
I run the 3DVA job with 20 modes a long time ago and I would like to run the job with the same parameters and the newest cryosparc v3.3.2.

@donghuachen The guide mentions these points relevant to the number of components:

“The costs”

the maximum is limited by GPU memory and the box size. Generally more modes will take (linearly) more time to solve.

“The benefits”

One subtle but important point is that the algorithm will generally solve these in order of importance, so asking for more modes will not reduce the quality of the first, most important modes of variability.

1 Like