3D Variability Job Error

I try to run a 3D variability job, but get an error after the two initial reconstructions have finished and the main iterations are about to start. This is the message:

[CPU: 8.56 GB]   Start iteration 0 of 20
[CPU: 8.56 GB]   Starting..
[CPU: 6.81 GB]   Traceback (most recent call last):
  File "cryosparc_worker/cryosparc_compute/run.py", line 84, in cryosparc_compute.run.main
  File "cryosparc_worker/cryosparc_compute/jobs/var3D/run.py", line 524, in cryosparc_compute.jobs.var3D.run.run
  File "cryosparc_worker/cryosparc_compute/jobs/var3D/run.py", line 359, in cryosparc_compute.jobs.var3D.run.run.M_step
  File "/home/cryosparcuser/cryosparc/cryosparc_worker/deps/anaconda/envs/cryosparc_worker_env/lib/python3.7/site-packages/pycuda/gpuarray.py", line 551, in fill
    value, self.gpudata, self.mem_size)
  File "/home/cryosparcuser/cryosparc/cryosparc_worker/deps/anaconda/envs/cryosparc_worker_env/lib/python3.7/site-packages/pycuda/driver.py", line 565, in function_prepared_async_call
    arg_buf = pack(func.arg_format, *args)
struct.error: required argument is not an integer

The system details:
CentOS 7
CryoSPARC 3.0.1
128 GB RAM
RTX2080Ti (x4)

Hi daniel.s.d.larsson,

I ran into the same error. Did you figure out the solution?

No, I did not find a solution to the problem.

Hi @daniel.s.d.larsson

I noticed that I got that error when I chose “no of modes to solve” as either 0 or 1.

1 Like

Thank you- I have been struggling with this for a full day!