3D reconstruction of simulated particles with high SNR

I am trying to do an ab initio 3D reconstruction of some simulated particles with high SNR (e.g., 1000) generated by the “Simulate Data (BETA)” job, but the results are very bad. Is there a way to turn of noise estimation in “Ab-initio Reconstruction”?

Hi @Steven,

There isn’t a way to disable noise estimation during ab-initio reconstruction, unfortunately. Regarding your findings, I have a few questions:

  • Which version of CryoSPARC are you running?
  • In what way are the results poor?
  • Is the sample highly symmetric?
  • Do you have enough particles with a wide variety of defocus parameters (this should be the case if the simulate data job was ran with default parameters)

Best,
Michael

1 Like

Hi @mmclean ,

I am using CryoSPARC v3.3.2+220518. There were 10,000 simulated particles and I turned off CTF parameters in the Simulate Data job. The results were poor because the reconstructed volume didn’t resemble the target volume at all. There is no symmetry in the target volume (I specified C1). As a test, I switched on CTF parameters in the Simulate Data job with default settings, and the ab initio results looked all right and the reconstructed volume had all the expected features. It seems like CTF must be present in the input projection images for ab initio reconstruction to work? Noise estimation seems to be able to adapt to the high SNR images.

Steven

Hi @Steven,

Ah, I see what the issue is. Right now, the simulator generates and writes CTF values to the particle cs files regardless of whether the “Apply CTF to images” parameter is activated. So if you disable it, the particle images will be just noisy projections with no CTF, but the simulated_particles.cs file will still have non-zero CTF parameters written to it. This creates a discrepancy between the image data and the metadata. Ab-initio requires that the CTF parameters in the cs file match the raw images, of course.

Right now there isn’t a workaround to resolving this discrepancy in the no-CTF case, unfortunately. However, as of our next upcoming release, there will be an option in 2D classification to overwrite the CTF of the particle stack with a constant (i.e. equivalent to setting CTF to the identity). Downstream jobs using these particles will then have the corrected metadata.

Best,
Michael

Got it. Thanks, @mmclean !