3D classification- Stuck in "Running"


I am trying to run the 3D classification in Cryosparc V3.3.1. I have extracted my particles, downsample them, 2D classification, Ab-initio and then run 3D classification on it with the Ab-initio all paritcles as input (all the parameters used are default) and this works perfectly fine! However, if I try to do the same thing with the extracted particles (not downsample) I get this error message:

[CPU: 2.56 GB] Traceback (most recent call last): File “cryosparc_worker/cryosparc_compute/run.py”, line 85, in cryosparc_compute.run.main File “cryosparc_worker/cryosparc_compute/jobs/class3D/run.py”, line 576, in cryosparc_compute.jobs.class3D.run.run_class_3D File "/home/ xxxx /software/cryosparc/cryosparc2_worker/cryosparc_compute/plotutil.py", line 934, in plot_alignment_dists fig.axes[2*k].set_title(‘Class %d’ % k) #Every second axis is a colorbar AttributeError: ‘NoneType’ object has no attribute 'axes’

I then though that it was something wrong with the extraction itself so I redid the extraction and I don’t get the above error message anymore. However, it does not want to run the 3D classification to the end. It says running even though it has been running over night, it seems stuck in the last alterations, I have tried both with the standard 10 classes but also only one class and both seem to behave the same.

Not really sure what to do next, I am very new to everything.

Hi @LCryoEM,

Welcome to using cryoSPARC! :). For the first error, can you provide a bit more information about the inputs to the job? The 3D Classification job requires particles with 3D alignments (e.g., from ab initio or from a homogeneous refinement) – however this should be verified when connecting a particle stack so shouldn’t raise this type of exception.

For the second point, the last iterations consist of a ‘full’ EM iteration that traverses the entire dataset. This will take longer, but a dataset with ~300K particles shouldn’t take this long. If you click ‘Show from top’ in the job modal:

You should see this output string that updates during the final iterations:

Is this updating when the job is ‘stuck’?

Hi @vperetroukhin and thank you for your reply! :slight_smile: I am using the particles from ab-initio reconstruction as input for the 3D classification, and in this run I have not added a volume. However I have tried to also run it with “input” (also adding a volume). I do the same thing with and without downsampling the particles, but it seems to only work with the downsampled ones.

After waiting around 24hrs the 3D classification fail for the not-downsampled particles unfortunately. It is “failing” after all of the iterations are done (please see picture under “Final”).
This is how the first and final iteration looks like, the final one is right before the error message pasted in my first post.



EDIT: After a bit of back and forth with Ab-initio and Refinement I got it to work! I add the particles from the refinement and the 3D classifications runs the whole way. I am not sure what was wrong, but thank you once again for the feedback!

1 Like