12.4 has terminated unexpectedly

request_recorded

#1

Hi I installed 2.12.4 from scratch and restored my old database. I get the below error for Patch Motion Correction. I have seen other people have similar problems but related to earlier versions. Do you have any suggestions?

This is a cluster install, and I have used earlier versions successfully before using cuda 8. I tried cuda 10.1.105 and 10.1.168 due to the higher cuda requirement of some of the steps in cryosparc, I tried to use gcc 6.3.0 however I am not sure how to specify CC=gcc for cryosparc installation. The default version of gcc in the system is 4.3.0 and when I install Relion, I load gcc/6.3.0 module and I have to to specify CC=gcc right before cmake command otherwise it picks the default 4.3.0 version. Please let me know how can I fix this?

Thank you

Traceback (most recent call last):
File “cryosparc2_worker/cryosparc2_compute/run.py”, line 78, in cryosparc2_compute.run.main
File “cryosparc2_worker/cryosparc2_compute/jobs/motioncorrection/run_patch.py”, line 312, in cryosparc2_compute.jobs.motioncorrection.run_patch.run_patch_motion_correction_multi
AssertionError: Child process with PID 7025 has terminated unexpectedly!


#2

Update: I re-installed the worker with cuda/9.2 and it is working now (by the way newcuda command has problems, FYI). I guess it is related to cuda/10.1. I thought cuda 10.1 was supported.

Would you please let me know if any process needs cuda 10 in cryosparc??? I think 3D variablity needs cuda >9 (I also think that this information should be on the installation guide, not many people will go into discussion forum and check this information specifically).

Thank you


#3

Hi @alburse,

Glad you got it sorted out. Yes, you’re correct, the newcuda command was out of date, but that is fixed and will be released in the next version of cryoSPARC.
The latest version of cryoSPARC includes new 3D Variability modes that require CUDA 10. We will update our documentation accordingly.


#4

Well, I sorted it out with Cuda9. It was giving error with cuda10. anyway I will wait for another couple of updates before installing again.

Thank you.