Workspace json missing


we are running cryosparc live on another instance than the actual cryosparc processing and thus transfer the projects from one instance to another quite frequently however. On several occasions we now have the issue that the workspace.json file was not generated and thus the import didn’t work.

Anything that we are doing wrong? Or anything we can do to fix this?



P.S. I already tried the tricks mentioned in other threads like adding an empty workspace but they dont work

Please can you describe this process in more detail. Is a copy of the Live project directory or its “original” imported to the second instance?
If the “original” project directory is imported to the second instance, it must be assured that the first instance can no longer modify the project directory after that import operation.

What we do is we mv the original project folder to a new location and the original instance doesnt have access there. It actually works in most cases. But sometimes there is no workspace json file generated and then we can already pretty much predict that it wouldnt work. I however have no clue why it is generated sometimes and sometimes not.

Hi @david.haselbach ,

What version of cryoSPARC are you running? (cryosparcm status will tell you)

v3.3.2 is written in the gui (I dont have access to cryosparcm in our setup)

We have identified an issue that may prevent workspaces.json from being created. As a temporary workaround, workspaces.json file creation can be forced by this sequence:

  1. pause all cryoSPARC Live sessions on the instance
  2. restart the instance
    cryosparcm restart

We recognize that this workaround can be disruptive and are working on a fix.


that didn’t help in two cases now.However: I did now the following that worked. I did the restart as you suggested but this didnt work right away so I added manually anotehr workspace, stared and stopped the run once more marked it as finished and than the workspace.json file appeared. I am not quite sure what caused it in the end.

I just wanted to ask whether there is any fix coming up? This is really a big issue for us.

A member of our team has written a script that forces creation of workspaces.json.

The script should be run before transfer of the project, if and only if workspaces.json was not created automatically.

Hi @david.haselbach,

This has been fixed as of the latest patch:

1 Like