Warp to cryosparc import

closed

#1

Hello everyone,

I am new in the cryoSparc community. So please excuse maybe simple questions:

I aim to import picked particle files from Warp into cryoSparc.

In Warp a folder named particles is created within the project folder containing the particle stacks (e.g. FoilHole_13710868_Data_13719033_13719035_20200314_160404_Fractions_BoxNet2Mask_20180918.mrcs)

Outside this folder a star file is written: goodparticles_BoxNet2Mask_20180918.star with the content below:

loop_
_rlnCoordinateX #1
_rlnCoordinateY #2
_rlnMagnification #3
_rlnDetectorPixelSize #4
_rlnVoltage #5
_rlnSphericalAberration #6
_rlnAmplitudeContrast #7
_rlnPhaseShift #8
_rlnDefocusU #9
_rlnDefocusV #10
_rlnDefocusAngle #11
_rlnCtfMaxResolution #12
_rlnImageName #13
_rlnMicrographName #14
   505.78   171.57  10000.0  1.22400  200.0  2.7000  0.100  0.0  19096.5  19082.9   73.0  7.0  0000001@particles/FoilHole_12686392_Data_13719033_13719035_20200315_005503_Fractions_BoxNet2Mask_20180918.mrcs  FoilHole_12686392_Data_13719033_13719035_20200315_005503_Fractions.mrc

I placed .star and all mrcs in one project folder and tried to import them into cryosparc with given particle data path (mrcs) and meta data path (star) with the following error message:

[CPU: 341.6 MB]  Reading particle data locations...

[CPU: 341.6 MB]    Reading rlnImageName to get indices and paths..

[CPU: 510.1 MB]    Warning: Parameter particle_blob_path was set, which overrides rlnImageName despite the latter being present in the input star file.

[CPU: 510.1 MB]  Traceback (most recent call last):
  File "cryosparc2_master/cryosparc2_compute/run.py", line 78, in cryosparc2_compute.run.main
  File "cryosparc2_compute/jobs/imports/run.py", line 106, in run_import_particles
    assert os.path.isdir(far_blob_path), "Parameter particle_blob_path was set but is not a file or a directory."
AssertionError: Parameter particle_blob_path was set but is not a file or a directory.

Can someone give me advice?

Kind greetings!


#2

Hi @mica84,

Can you provide the exact strings that you use as input for the
“Particle meta path” and “Particle data path” inputs?
Note you should not have any * wildcard in either one. The correct way to import particles like this is either:

  • keep the folder structure as-is from Warp (.star file outside and .mrcs files inside “particles” folder). In the cryoSPARC import job, only specify the .star file path. cryoSPARC will find all the .mrc files itself, using the _rlnImageName from the .star file.

OR

  • keep the folder structure as you have done (.star file and .mrcs files all in one place). In the cryoSPARC import job, set the “particles meta path” as the .star file, and set the “particles data path” as the folder that contains the .mrcs files (not the .mrcs files themselves).

#3

Thanks a lot. Indeed I used a wildcard before I tried option 2 and it worked directly!