V 2.14.2: unable to merge 2 sets of particles for 2D classification


I did try to input 2 sets in the 2D classification input box but the job only takes the first set into account.
and I tried to use the particle set tool but it does not show the union tool . I only see the split and intersect tools in the menu.
One set was imported from another projet, but it looks OK to me.
thanks for your help,

Hi @valbibpc ,

How did you determine that the 2D class job is not using all the particles?

When you use particle sets, can you try computing the intersection? Just as a sanity check - the intersection should have zero items.

Hi @apunjani,

my sets have
J29: 109343 particles (imported from another project)
J28: 188977 particles
when I try to run 2D classification, it uses only 188977 particles.
when I try to run particle sets tools, I only have Split or Intersect menu.

as you adviced, I tried intersection but it fails :

License is valid.

Running job on master node

[CPU: 94.3 MB]   Project P3 Job J40 Started

[CPU: 94.3 MB]   Master running v2.14.2, worker running v2.14.2

[CPU: 94.4 MB]   Running on lane default

[CPU: 94.4 MB]   --------------------------------------------------------------

[CPU: 94.4 MB]   Importing job module for job type particle_sets...

[CPU: 94.4 MB]   Job ready to run

[CPU: 94.4 MB]   ***************************************************************

[CPU: 94.4 MB]   Operating on particle. Action is intersect. Slot that will be used during output is blob.

[CPU: 94.6 MB]   Traceback (most recent call last):
  File "cryosparc2_master/cryosparc2_compute/run.py", line 82, in cryosparc2_compute.run.main
  File "cryosparc2_compute/jobs/utilities/run_sets.py", line 69, in run
    rc.log('Inputted %d items as set A' % len(input_A_dset))
TypeError: object of type 'NoneType' has no len()

Hi @valbibpc,

Thanks for reporting.
In the Particle set tools job, did you connect J29 to set A and J28 to set B?
Can you look inside the J29 job directory and list for us the contents?

Hi @apunjani,

Job J40 had J29 in A and J28 in B. Here are the directory contents:

J29 directory

-rw-r--r-- 1 cryosparc_user cryosparc_user 969722 mai    2 14:49 events.bson
drwxr-xr-x 2 cryosparc_user cryosparc_user   4096 avril 28 21:46 gridfs_data
-rw-r--r-- 1 cryosparc_user cryosparc_user  28820 mai    2 14:49 job.json
-rw-r--r-- 1 cryosparc_user cryosparc_user    718 mai    2 14:49 P3_J29_particles_excluded.csg
-rw-r--r-- 1 cryosparc_user cryosparc_user    162 mai    2 14:49 P3_J29_particles_selected.csg
-rw-r--r-- 1 cryosparc_user cryosparc_user    248 mai    2 14:49 P3_J29_templates_excluded.csg
-rw-r--r-- 1 cryosparc_user cryosparc_user    247 mai    2 14:49 P3_J29_templates_selected.csg

and J28 (total 85008)

-rw-r--r-- 1 cryosparc_user cryosparc_user     7809 mai    2 14:39 events.bson
drwxr-xr-x 2 cryosparc_user cryosparc_user     4096 avril 28 17:29 gridfs_data
-rw-r--r-- 1 cryosparc_user cryosparc_user    30999 mai    2 14:39 job.json
-rw-r--r-- 1 cryosparc_user cryosparc_user     1424 avril 28 17:29 job.log
-rw-r--r-- 1 cryosparc_user cryosparc_user      710 mai    2 14:39 P3_J28_particles_excluded.csg
-rw-r--r-- 1 cryosparc_user cryosparc_user      715 mai    2 14:39 P3_J28_particles_selected.csg
-rw-r--r-- 1 cryosparc_user cryosparc_user 10811661 avril 28 17:29 P3_J28_passthrough_particles_excluded.cs
-rw-r--r-- 1 cryosparc_user cryosparc_user 38363227 avril 28 17:29 P3_J28_passthrough_particles_selected.cs
-rw-r--r-- 1 cryosparc_user cryosparc_user      248 mai    2 14:39 P3_J28_templates_excluded.csg
-rw-r--r-- 1 cryosparc_user cryosparc_user      248 mai    2 14:39 P3_J28_templates_selected.csg
-rw-r--r-- 1 cryosparc_user cryosparc_user  8308596 avril 28 17:29 particles_excluded.cs
-rw-r--r-- 1 cryosparc_user cryosparc_user 29481228 avril 28 17:29 particles_selected.cs
-rw-r--r-- 1 cryosparc_user cryosparc_user     2800 avril 28 17:29 templates_excluded.cs
-rw-r--r-- 1 cryosparc_user cryosparc_user     1216 avril 28 17:29 templates_selected.cs

Best, Valerie

Hi @valbibpc,

Is it possible if you can open the file P3_J29_particles_selected.csg and paste the contents here?

Hi @stephan,

here is the content of P3_J29_particles_selected.csg
created: 2020-05-02 12:49:29.514084
description: ‘’
name: particles_selected
title: Particles selected
type: particle
results: {}
version: v2.14.2


Hi @valbibpc,

Is it possible if you can click “Export Job” on the original job to re-export the job, then re-import the job into your project by copying the exported job into a folder inside the project (e.g. P12/imports)?