Unarchive Failing

Hi - I recently tried going back to an old cryosparc project I had archived. When I tried unarchiving it gives an error message of:

Unable to unarchive P20: ServerError: unarchive error: project lock file not found at given project directory

I can see the directory on our server and I can see the cs.lock file in the folder. I’m wondering if this has something to do with it being an older directory with the P20 name of the folder instead of the cs-ProjectName format? Is there a way to unlock this directory or do I need to start fresh? Thanks.

@hansenbry Please can you confirm that the Linux account on the master host can traverse and read the entire path to the project directory and the cs.lock file.

Hi @wtempel - I have confirmed that the file and directory are viewable by the account on the master host and are owned by that account.

Thanks @hansenbry for confirming this. Please can you email us the tgz file created by the command
cryosparcm snaplogs.

@wtempel sorry it took me so long to get back to you. I had to have our IT group check the output and make sure I was able to share those logs. I have them, but it looks like I can’t attach them in a reply

@hansenbry I sent you a private message with the appropriate email address 3 day ago. Did you receive it?

Hi @wtempel sorry I missed that notification. Got it thanks.

@wtempel just checking if my email with the logs made it to the team

Thanks @hansenbry, we did receive the logs. Given the logs and information under this topic so far, the best guess is that the path provided during unarchiving did not match the absolute path to the project directory where you confirmed the presence of the lock. You may also want to confirm that the relevant project directory’s cs.lock file was not manipulated, such as during troubleshooting and recovery attempts and try on a terminal

export dir_to_unarchive="/absolute/project/path"
whoami # must be Linux account that owns cryosparc processes
ls -ls ${dir_to_unarchive}/cs.lock
grep '"uid"' ${dir_to_unarchive}/project.json # Confirm P20
cryosparcm cli 'unarchive_project("P20" , "'$dir_to_unarchive'")'

What is the output?

[Edited: corrected command line]

@wtempel Here’s what we got

[cryo1@ai-rmlcryoprd1 ~]$ export dir_to_unarchive="/gs1/RTS/EM/Projects/cryoSPARCprojects/P20"

[cryo1@ai-rmlcryoprd1 ~]$ whoami

[cryo1@ai-rmlcryoprd1 ~]$ ls -ls ${dir_to_unarchive}/cs.lock
1 -rw-rw-r--. 1 cryo1 rmlem 99 Oct 13 13:12 /gs1/RTS/EM/Projects/cryoSPARCprojects/P20/cs.lock

[cryo1@ai-rmlcryoprd1 ~]$ grep '"uid"' ${dir_to_unarchive}/project.json
    "uid": "P20",

[cryo1@ai-rmlcryoprd1 ~]$ cryosparcm cli 'unarchive_project("P20" , "'$dir_to_unarchive'")'


Just as I would expect for a successful unarchive operation. Can you now interact with the project on web browser interface?

@wtempel I can open, view, and download items from the archived project. Just can’t do anything new obviously and can’t unarchive.

Please can you run the command

cryosparcm cli "get_project('P20')"

and post its output.

@wtempel here’s the new output

[cryo1@ai-rmlcryoprd1 ~]$ cryosparcm cli “get_project(‘P20’)”

{‘_id’: ‘61c0f80cd4d100aa6b8f1490’, ‘archived’: False, ‘created_at’: ‘Mon, 20 Dec 2021 21:39:24 GMT’, ‘deleted’: False, ‘description’: ‘Enter a description.’, ‘detached’: False, ‘generate_intermediate_results’: False, ‘hidden’: False, ‘last_accessed’: {‘accessed_at’: ‘Tue, 15 Nov 2022 21:53:33 GMT’, ‘name’: ‘hoytf’}, ‘last_exp_group_id_used’: 1, ‘owner_user_id’: ‘5e28d587abd3b632bdd24ad8’, ‘project_dir’: ‘/gs1/RTS/EM/Projects/cryoSPARCprojects/P20’, ‘project_params_pdef’: {}, ‘project_stats’: {‘job_count’: 181, ‘job_sections’: {‘ctf_estimation’: 2, ‘ctf_refinement’: 4, ‘extraction’: 3, ‘import’: 4, ‘live’: 53, ‘local_refinement’: 5, ‘motion_correction’: 11, ‘particle_curation’: 15, ‘particle_picking’: 3, ‘postprocessing’: 20, ‘reconstruction’: 4, ‘refinement’: 47, ‘utilities’: 6, ‘variability’: 4}, ‘job_status’: {‘building’: 2, ‘completed’: 152, ‘failed’: 7, ‘killed’: 20}, ‘job_types’: {‘class_2D’: 5, ‘class_2D_streaming’: 12, ‘class_3D’: 3, ‘create_templates’: 1, ‘ctf_refine_global’: 2, ‘ctf_refine_local’: 2, ‘downsample_particles’: 1, ‘export_live_exposures’: 2, ‘export_live_particles’: 1, ‘extract_micrographs_multi’: 2, ‘generate_thumbs’: 3, ‘hetero_refine’: 3, ‘homo_abinit’: 4, ‘homo_refine_new’: 35, ‘homo_refine_streaming’: 2, ‘import_movies’: 2, ‘import_volumes’: 2, ‘inspect_simple’: 1, ‘live_session’: 3, ‘local_filter’: 5, ‘local_motion_correction’: 1, ‘local_motion_correction_multi’: 5, ‘local_resolution’: 11, ‘new_local_refine’: 5, ‘nonuniform_refine_new’: 9, ‘patch_ctf_estimation_multi’: 2, ‘patch_motion_correction_multi’: 5, ‘rtp_worker’: 33, ‘select_2D’: 10, ‘sharpen’: 4, ‘sym_expand’: 1, ‘template_picker_gpu’: 1, ‘var_3D’: 1, ‘volume_tools’: 2}, ‘session_count’: 3, ‘updated_at’: ‘Mon, 16 Oct 2023 15:25:18 GMT’, ‘workspace_count’: 3}, ‘queue_paused’: False, ‘size’: 14868943869369, ‘size_last_updated’: ‘Thu, 13 Apr 2023 19:21:41 GMT’, ‘status’: ‘completed’, ‘title’: ‘NIEHS SARS-CoV-2 Spike’, ‘uid’: ‘P20’, ‘uid_num’: 20, ‘users_with_access’: [‘5e28d587abd3b632bdd24ad8’, ‘60de37a781416b47997ffd7c’, ‘5f6b596eabd3b60e9054e53d’, ‘61e1ba5ac88c3519c79c90e5’]}

This project is not archived. Does it still show as Archived on the web browser interface? Could there be a mix-up between projects?

@wtempel so it had been showing archived in the UI, but after the last cryosparcm cli command now it’s showing not archived anymore and I’m able to create jobs again.

1 Like

Hi @hansenbry,

In the latest CryoSPARC v4.4.1:

Attempting to unarchive a project will now fail if the directory specified does not contain a the same project UID that is being unarchived. The target project directory’s project.json file is checked to see if it matches the UID of the project selected in the UI.

Hopefully this change will prevent this issue from coming up again.

1 Like