Topaz jobs are failing

Hi all,

when I tried to run topaz jobs that failed with the topaz version did not produce. I used/programs/x86_64-linux/system/sbgrid_bin/topaz as executable.

Hi @wtempel,

could you help on this


@rajesh Please can you

  1. post error messages as text (why?)
  2. try installing topaz into a dedicated conda environment
    conda create -n new_env_name python=3.6
    conda activate new_env_name
    conda install topaz -c tbepler -c pytorch
    (see GitHub - tbepler/topaz: Pipeline for particle picking in cryo-electron microscopy images using convolutional neural networks trained from positive and unlabeled examples. Also featuring micrograph and tomogram denoising with DNNs.)
  3. create and configure executable wrapper script
  4. retry the job pointing Path to Topaz executable to the wrapper script.
1 Like

Try instead using
/programs/x86_64-linux/topaz/<your version>/bin/topaz
or maybe but not likely

Interesting. @drichman If this worked for you, what was <your version> and what was the CryoSPARC version?

Pardon my vagueness :grimacing: At the moment it’s Topaz 0.2.5_cu11 and CryoSPARC 4.4.1. But for previous combinations of Topaz and CryoSPARC versions I’ve also used this approach of just installing Topaz through SBGrid and using the executable in that bin directory.

1 Like