Threads and mem setting in orientation diagnostics

Hi -

I tried to run “orientation diagnostics” with v 4.4.1 installed on a slurm cluster, and even though I set “number of threads” to a number larger than 1, in the submission script “num_cpu” is always set to 1. Is it a known bug or something wrong on our side?

Also, probably linked to this, it fails with “Job process terminated abnormally” . Looking at the log, it looks like it comes from a OOM (we were asked to not set “mem” explicitly; on this cluster, 4GB are automatically associated to each core requested).


I don’t think CryoSPARC can work with just 4GB of RAM per core, but the developers can chime in with more detailed information on that front.

1 Like

thanks - I managed to make it run modifying the template script (though it’s still a bit unclear if the “number of threads” options is managed)

Hi @ncoudray – thanks for reporting this. This is indeed a bug in the current version of orientation diagnostics (the resources aren’t correctly updated). We’ll fix this in an upcoming release.


1 Like