Template picker in v.4.1.2 memory error

I am trying to use templates generated from a volume and get the following error message

[CPU: 352.0 MB Avail: 122.15 GB]
Traceback (most recent call last):
File “cryosparc_master/cryosparc_compute/run.py”, line 96, in cryosparc_compute.run.main
File “cryosparc_master/cryosparc_compute/jobs/template_picker_gpu/run.py”, line 61, in cryosparc_compute.jobs.template_picker_gpu.run.run
File “cryosparc_master/cryosparc_compute/jobs/template_picker_gpu/run.py”, line 237, in cryosparc_compute.jobs.template_picker_gpu.run.do_pick
File “cryosparc_master/cryosparc_compute/jobs/template_picker_gpu/template_pick_gpu.py”, line 171, in cryosparc_compute.jobs.template_picker_gpu.template_pick_gpu.rotate_downsample
numpy.core._exceptions._ArrayMemoryError: Unable to allocate 168. GiB for an array with shape (8, 72, 8860, 8860) and data type float32

Another strange issue, and I assume with a related cause, is that the images of the templates in the template picker event log do not match those from the create template job. In the event log they are displayed as blank, grey squares. The create template image shows each template as expected, looking like the map they were generated from. The first pictures are the templates as they look from Create Templates, the second is what an individual template looks like in the Template Picker event log.


Initially I generated the default 50 templates from the map volume I imported, with the “Unable to allocate” number being much higher. The workstation has 256 GB of memory, more than the 168 apparently needed for this job, which had only 8 templates. I’m using only 250 movies while optimizing other parameters, so it’s not like I’m running a 4000 movie set and running out of swap or storage space.

Strangely, if I use templates from Select 2D, this issue does not occur. I used 14 templates from Select 2D successfully with the exact same set of movies, same settings for template picker; cloned the successful job and replaced only the templates. The pixel box value was 280, I also tried reducing that to 70 (four-fold reduction), but the error persists.

cryoSPARC v.4.1.2

Any assistance is welcome, thank you.

From what upstream job type did you connect the micrograph input for this job? Please can you show a screenshot of the Inputs tab?

I used the movies from a prior blob picker run that used the same 250 movies. I was using a subset of movies to optimize some parameters. I’ did the same thing earlier with template picker and the same movies from blob picker, but using templates from Select 2D, and that worked with no issues.

Figured it out, accidentally put the box size instead of the pixel size in the import volume job preceding generate templates, and then template picker.