Solution to this issue: pycuda._driver.MemoryError: cuMemAlloc failed: out of memory

I am working on single particle picking for CryoEM micrographs. I face “pycuda._driver.MemoryError: cuMemAlloc failed: out of memory” while importing micrographs, Motion correction, CTF estimation or any jobs.

I have 32 GB RAM and 2 GPUs (98GB + 6 GB)
Here is the screenshot of nvidia-smi.

Can you let me know what is causing this issue and how can I resolve?

What micrographs are you processing? Super resolution K3 and 8K EER will run out of VRAM on 8GB cards. You can turn on low memory mode in the advanced settings for motion correction, but it will slow down motion correction quite a bit.

I’d avoid running anything on the 6GB card unless it was small-box 2D classification, <8GB cards run out of memory too easily.