Reslog problem with data set size

I’m running a Reslog for the first time within cryoSPARC v2.14.2, and the jobs repeatedly fail with the same AssertionError, which is “Please ensure data set size is greater than the starting point data set size!”
My input to the job is ~ 30,000 particles and I have kept all default values for the Job Details, except that I have initiated different jobs (all failed with the same AssertionError) using different Initial sample size (100 or 1,000) in the ResLog Setting field. I must be missing something basic and my Google-Fu is failing me. Please advise.


Hi @earturo, here’s some information on what input the Reslog job expects:

Reslog requires particles input group from a refinement job including a particles.alignments3D output. This output includes information about how the particles were randomly split into two groups for the Gold-standard refinement.

The “Initial sample size” parameter must be smaller than the [size of the particle stack] divided by 2.

Based on the number of particles and initial sample size value you specified, Reslog should be working. Double check that (1) you specify particles from a refinement job with enough particles that includes the alignments3D output:

and (2) that the “Initial sample size” parameter is smaller than the specified number of particles.

Also check the top of your job log for the following:

  • A line that contains “Maximum particle images in each half: xxxxx”: The “xxxxx” should be a number about half the size of your dataset, around ~15,000 or so
  • A line that contains “Number of particles to use for EACH half-set in refinement [ … ]”, where the [ ... ] contains a list of numbers starting with the smallest number equal to the specified “Initial sample size”
  • If you’re using SSD caching, a line like “Loading a ParticleStack with yyyyy items…”, where “yyyyy” is the number of particles you expect in particles input

For example, here’s what a healthy job log with ~60,000 particles should look like:

Hope that helps; if not, send me the first 40 lines or so of the Reslog job log so I can troubleshoot further.